Local Community

The site will not stay local

Issue Summary

As soon as I go to the wp-admin, the site goes live instead of staying local.

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular? Just the one that I have downloaded the files to.

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser? Yes

Replication

Installed a new WP.
I used my Updraft Plugin to upload then restore my backup to the local site.
I have all of the files in local.
The site domain is set for local.
When I go to wp-admin, it just goes to the live site immediately instead of staying in the local dev env.

Any help will be greatly appreciated.

System Details

  • Which version of Local is being used? Latest

  • What Operating System (OS) and OS version is being used? Linux Mint

    • For example: macOS Catalina or Windows 10 Professional
  • Attach the Local Log. See this Help Doc for instructions on how to do so:

local-lightning.log (36.7 KB)

Security Reminder

Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi there @mikekingapp - thank you for bringing your question to the Local Community! :wave:

When you say “the site goes live” do you mean Live Links? If so, can you disable that?

If that doesn’t help, feel free to share a screen-share video (you can use Loom to create one for free) or a screenshot to help explain what you’re seeing.

Thank you!

:woman_technologist:t3: Sam