Local Community

Tips for debugging a website that won't start

Issue Summary

Note:
I am an experience software developer but am new to Local and Wordpress in general and am seeking direction.
I’ve imported a client’s website into an instance in Local and when trying to open the site, the web page hangs forever or sometimes (if left long enough) throws a my_sqlerror error that i am unable to track down so far. The website in question was built in 2019, is up and running and i am unable to get it running in Local. Looking for tips on how to debug! See Replication Steps below for more info.

Troubleshooting Questions

Just this one in particular.

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?
    yes

Replication

Am following the steps here for importing the client site to my local instance:
https://localwp.com/help-docs/getting-started/how-to-import-a-wordpress-site-into-local/

The existing website is fairly old, built in 2019, running on MariaDB 10.3.x and running WP 5.3.8. I created a zip file of the wp-content folder from the website along with a database export as described above. By following the instructions above, the site IS created successfully (with minor database import errors). To do this, i am using the client’s php version that they are running live (5.6.39) and the closest MySQL cousin to the MariaDB version above which i determined to be MySQL 5.7.28.

Here the problems begin.
I AM able to go into Adminer and see the database and it looks fine. When i attempted to start the site (by “Open Site”), the page request takes FOREVER and never actually loads in the browser. My first guess was to check the WP version the site was running. So, i dug into it some and discovered that in the import process, Local does not ask for the desired WP version (which in my case would be 5.3.8) and is running 5.7.2. Before i discovered this import process yesterday, i was trying things and was routinely able to migrate back to an earlier version of WP with the following site shell command: “wp core update --version=5.3.8 --force”. However, now this command no long works (as it did yesterday but i was attempting other import methods). It hangs forever. Not sure why since this worked very well yesterday on other attempts. This is the error that comes up eventually:
" Error: There has been a critical error on this website. Learn more about troubleshooting Wordpress."

So, using this import method, i need assistance figuring out how to go back to an earlier WP version.

Provided that i can somehow figure out a way to de-migrate this installation back to 5.3.8, if the problem that i originally started with still exists, i’m really seeking some tips on how to debug what is going on. My original problem was that the local site would hang forever when i tried to “Open Site”. Does Local have any tools that would be helpful? Thanks for the help, i am attaching the local-lightning.log and error.log files. The instance that i am attempting to create is called “fasnew” and the relevant log entries would be from today (July 13).

System Details

  • Which version of Local is being used?
    5.10.5+5403

  • What Operating System (OS) and OS version is being used?

    • For example: macOS Catalina or Windows 10 Professional
      MacOS Big Sur
  • Attach the Local Log. See this Community Forum post for instructions on how to do so:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.