Cannot get Import, or Add New Site to work

What issue or error are you experiencing?

Cannot get the software to work using Import, or Add


What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc.

I need to test a number of websites with MySQL 8.X. I tried using WAMP server, but having a lot of trouble with that. I’ve used Local to “Connect and Pull” six websites from WordPress Engine and that all seemed to go just fine. Now I have a number of websites on other hosts that I have downloaded along with their database.

First I tried to Import them and keep getting the error message “Please try again with a compatible .zip file”. I’ve followed the troubleshooting techniques found on this forum and nothing works (like only putting the wp-content folder and the database in the .zip file). The next thing I tried was to create the Wordpress files using the “Add New Site” function in Local. Even that doesn’t work and I get an error message that it was unable to create a wp-config file (see attached screen capture. Not quite sure what to do next :frowning:


System Details

  • Local Version:
    7.1.2 +6410

  • Operating System (OS) and OS version:
    Windows vers. 10


Local Logs


local-logs.zip (528.1 KB)


Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

I’ve managed to resolve the issue. Seems odd to have to go through all of this.

When using “Add new site”, even though I got the error message about the wp-config file, it did create all of the other Wordpress files. So, I took a copy of the original wp-config file and placed it in the folder. I then replaced the wp-content folder with the same from the original website. I now took the “app” folder that Local created and added a new folder named “sql”. I placed a copy of the original database into the sql folder and then zipped the app and sql folders together into a single .zip file.

After this, I deleted all of the files from the Local folder and then Imported the newly created .zip file. This seems to have worked. I then had to go through the steps found in the Local documentation to create an admin user, so I could access the WordPress admin panel in the site.

a lot of steps to make this work.

@mcaravaglia

Glad you were able to get things working!

Our general recommendation when users run into this error is to try honing their zip file down to just the necessary WP-Content and SQL files. Sometimes that will resolve the import error, but if a more manual import is needed the basic steps are like this:

  • Unzip the file in a common location, like the desktop
  • Create a new, blank site in Local. Use whatever username/password you like since you’ll overwrite the DB with this site archive’s dump.
  • Copy the wp-content folder from the unzipped location to this newly created site’s location
  • Copy the correct SQL dump to the site root.
  • Within Local, open the site shell
  • Import the dump with wp db import <dumpfile>
  • If that works, now Search and replace the domains. wp search-replace ' https://production.com ' 'http:mylocalsite.local'

WP Migrate Lite is a free plugin that you can also use to create a tailored zip file of your site to be able to import into Local. Instead of doing the “full site export” you can just pick and choose the necessary files to take.