Tried to change PHP version on 1 site, Local crashed, now no sites open

What issue or error are you experiencing?

Had 1 site open and tried to change the PHP version. Local then showed several other sites (that weren’t open) as “provisioning”. It stayed in this state for a couple hours till I finally closed Local. Upon reopening it can’t find the PHP version for any site and therefore won’t open any sites.


What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc


System Details

  • Local Version:
    9.0.3
  • Operating System (OS) and OS version:
    Mac M1 Sonoma 14.4.1

Local Logs

Attach your Local L
local-lightning.log (949.8 KB)
ogs here (Help Doc - Retrieving Local’s Log)


Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Sorry that you encountered this, @DavidG.

On macOS you can try:

  1. Stop all sites and quit Local.
  2. Open the Finder.
  3. Choose Go → Go to Folder, paste the following and press Enter:
    ~/Library/Application Support/Local/lightning-services/.
  4. Delete all folders in the lightning-services folder.
  5. Start Local and start your site - it should redownload the corrupted version of PHP.

That worked (mostly) - thanks!

I may have found the issue (or part of it). If I try to download PHP 8.3 through Local it hangs. I noticed in the lightning-services folder that for php-8.3 it never downloads the bin folder. Also, while Local is hanging as it tries to download PHP 8.3 it somehow cuts off my internet access and no websites will load. As soon as I force quit Local the internet works fine. If I don’t try to download 8.3 everything works great.

I wonder if this is related to why I have to update Local manually each time. If I click the update button when there’s an update for Local, it hangs and I lose internet. I have to force quit Local, install the update manually, and then all is good.

Any ideas why downloading all PHP versions works fine except 8.3? Or why I lose internet when Local hangs (either when trying to download PHP 8.3 or update Local)?

Hey @DavidG!

I remembered from a previous thread you mentioned you’re working on a strong home connection with no VPN correct?

Do you have any sort of firewall or security applications running?

How many sites do you have in Local? Do you typically work with several sites at a time?

Are any of the sites overly large with lots of media, massive DBs, etc? Multisites?

Correct. 940mbps. No VPN. I thought my firewall was on, but it wasn’t. It is now (the built-in Mac firewall). I also use Bitdefender Antivirus.

I have 50 sites in Local and typically only have 1 running at a time (though occasionally 2-3). But any time I’ve tried to do an update has been when Local first opens. So that issue happens when I have no sites open. It happened while downloading PHP 8.3 when only 1 site was open.

There are 3-4 ecommerce sites where all data combined is 20 - 60gb per site. These sites have not been running recently and have not been open when encountering the issue. There is only 1 multisite and it only has 2 sites (both rather small).

The update issue has only been for the last two updates. I’ve used Local for years and never had this issue before. Also, when I deleted all PHP versions in /lightning-services/, all versions downloaded and worked fine, except 8.3. Only 8.3 caused Local to hang and killed my internet. And to clarify, I only deleted the PHP folders in /lightning-services/ - not sure if that matters.

With all of those sites and everything I’m assuming your disk space is pretty robust? Do you have plenty of overhead there?

I have a 1tb disk with 322gb free.

Thank you for the responses here @DavidG! I’m a bit at a loss, but we had another user who came in with a similar issue. They were able to resolve this by switching from their Broadband connection to a dedicated IP through VPN. There could be a lot of contributors to intermittent connections through Broadband, but it’s curious they never had problems until recently either.

@nickc Is there anything that may have changed with the way we update PHP 8.3 or Local v9 that creates a bit more strain on these download connections? Or could it just be coincidental?

I tried moving the Local app to trash and redownloading/installing and that seems to have fixed the issue. So far any site pulls (another thing I discovered would just hang), and updating to PHP 8.3 have worked without issue.

Looking forward to the next Local release to see if that update works!

2 Likes

Just confirming that nothing has changed recently around downloads/site connections. But glad that a reinstall seems to have solved things for now.

1 Like