Trojan error / "Failed to decompress files" on Local 6.7.0

Bug Summary

I face this error when installing localwp
failed to decompress files please try running the installer again

Steps to reproduce

As precisely as you can, list the steps it takes to reliably reproduce the issue.

Environment Info

Describe your environment.

  • What Operating System are you using?
  • What versions of site software (Nginx, Apache, PHP, MySQL) is used?
  • What version of Local is installed?

Supporting info

Please provide your Local Log. See this Community Forum post for instructions on how to do so:

Include any screenshots or video recordings of the issue to help others reproduce.

Same story. can’t open my Local :frowning:
I’m using Windows.

Hi @ingule422

Do you have any antivirus, security, or firewall applications that could be blocking Local? Are you running any other developer applications simultaneously?


What is your OS? Can you provide a copy of your local log? Retrieving Local’s Log File

More details about that error Failed to Decompress error here

Looks like this update is being flagged by Windows Security as a threat:


Hello all! Just a heads up here:

1 Like

¡Hello! I have the same problem, I tried to install the 6.7.0 version and now I can’t join to my Local app.


Bug Summary

As per title, latest update deletes Local but does not install new version.

Steps to reproduce

Click the prompt to update to the latest version.

Environment Info

Describe your environment.

  • What Operating System are you using?

  • What versions of site software (Nginx, Apache, PHP, MySQL) is used?

  • What version of Local is installed?

None of the above because it’s all gone.

Supporting info

During the update it had some error about not being able to unzip a file?

When I go to add/remove programs in Windows control panel, Local is no longer listed.

So in an attempt to re-install I just downloaded the latest version from the site – 6.7.0 – and got the same error. Screenshot attached.

Tried running installer as admin, and tried both options, installing for everyone and current user, same result.

Hi @Youdaman

Do you have any antivirus, security, or firewall applications that could be blocking Local? That is usually the culprit here: Failed to Decompress

This issue is followed by Windows Defender blocking installation because of Trojan threat
Here is the issue

Thanks @Nick-B and @rilel – just re-installed 6.6.1 without needing to turn off anti-virus, thanks for the tip re 6.7.0 requiring this to avoid a false positive.

Will all the future versions require turning off anti-virus because I can imagine in some workplaces this is not possible, and also some people might not want to do that regardless.

Hi @Youdaman! Our Local Dev team is looking into this right now after reports from multiple Windows users coming across similar issues with 6.7.0. We will keep you posted as we know more and hopefully find a resolution that makes this smoother moving forward :slight_smile:

1 Like


Today I tried to update Local to v6.7.0 on my W10 pc and I get this error “Failed to decompress files. Please try running the installer again. Error opening ZIP file”

I tried to update firstly on the app then I tried installing via latest update available on the website by downloading.

I also tried as Admin. Nothing’s work.

Let me know if you guys already had this issue and fixed it.

Thanks in advance for every help around !
local error screenshot

1 Like

Issue Summary

While upgrading from 6.1.1 to 6.7.0 Windows Defender alerted a Trojan:Script/Sabsik.FL.B!ml

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?
    Happens while upgrading or reinstalling 6.7.0

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?
    Since not being able to install, no


Describe the steps that others can take to replicate this issue. If you have screenshots that can help clarify what is happening, please include them!
While installation v6.7.0 windows defender finds a trojan and the installation is stopped. This is what windows shows:

System Details

  • Which version of Local is being used?

  • What Operating System (OS) and OS version is being used?

    • For example: macOS Catalina or Windows 10 Professional
      Windows 11 Pro
  • Attach the Local Log. See this Help Doc for instructions on how to do so:

    • Retrieving Local’s Log
      {“localVersion”:“6.6.1+6281”,“osPlatform”:“win32”,“osRelease”:“10.0.22621”,“osArch”:“ia32”,“windowsEdition”:“Microsoft Windows 11 Pro”,“linuxEdition”:null,“level”:“warn”,“message”:“Electron Event ready”,“timestamp”:“2023-03-23T13:06:13.753Z”}
      {“localVersion”:“6.6.1+6281”,“osPlatform”:“win32”,“osRelease”:“10.0.22621”,“osArch”:“ia32”,“windowsEdition”:“Microsoft Windows 11 Pro”,“linuxEdition”:null,“level”:“warn”,“message”:“Electron Event ready”,“timestamp”:“2023-03-23T13:18:23.728Z”}

Security Reminder

Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

1 Like

I ran in exactly the same problem just a couple of minutes ago. I tried to update Local and got the Torjan warning. Form me it is a other Trojan though: Trojan:Script/Wacatac.H!ml

Reinstalling from the homepage causes the same problem.

I have exactly the same issue this morning. When trying to install Local from the site homepage, got the same threat warning

I hit the same problem. Failed both upgrade and installing from the website. Both times Windows Defender reported:


Detected by Microsoft Defender Antivirus

Aliases: No associated aliases


Microsoft Defender Antivirus detects and removes this threat.

This threat can perform a number of actions of a malicious hacker’s choice on your PC.

Find out ways that malware can get on your PC.

What to do now

Use the following free Microsoft software to detect and remove this threat:

You should also run a full scan. A full scan might find other hidden malware.

Get more help

You can also see our advanced troubleshooting page for more help.

If you’re using Windows XP, see our Windows XP end of support page.

Hi all - I’ve merged several threads in here that are all related to the Trojan error or the “Failed to decompress files” error message. Both are due to Windows Defender flagging the latest Local release in a false positive.

Thank you for bringing this to our attention! We’re going to try resigning and republishing the build to see if that resolves the issue as it has worked for other apps that reported this issue. We’ll report back as soon as we’ve got a republished build.