Error Update or Install to Localwp version 8.2.0

Every time there is an update I have the same problem on different computers with Windows 10 and 11 Pro. An error appears indicating that I should close the application manually, but the application is already closed, even if the computer has just restarted, nothing appears in the windows task manager, and the error appears whether you update or try to reinstall the application.
This is not the first time this has happened to me with other previous updates.

Hey @Imaxenio – great to hear from you again!

Windows has been tricky for us in terms of cleanly terminating processes. We have made adjustments (I think in 8.0.0) to try and get better at killing those processes, but it’s possible that it’s not working correctly.

Can you give us a little more detail about what’s going on leading up to when you see this error:

  • Do you click the “Upgrade” button from within Local, or are you manually downloading a new version from the releases page?
  • How did you originally install Local? During the installation, I think that it asks for “Globally” or “Just for this user”
  • When you first installed Local, was it a regular install, or run as an “Administrator”?

Lastly, can provide the Local Logs? You can get a zip of those logs by clicking the “Download Local Log” button from the “Support” tab of Local. See this help doc for more information:

Thank you,
I have already tried everything you say, and installing as administrator, and even trying to update after running Localwp as administrator, both in global and user mode, I always get the same problem, it tells me that it could not close the application and to close it manually, but nothing appears in the windows task processes. I have even tried to see if for some reason Nginx or Apache remained activated and nothing, impossible to update. I believe that if the applications included in Localwp were portable versions instead of installable, this should not happen. I also use Laragon for other developments and have never had these problems. It is a pity.

But Local shouldn’t be run as an administrator – that’s part of what I’m wondering is if it’s running as an admin, maybe it is spawning processes that can’t be closed cleanly?