Trust SSL certificates in 6.3.1

Hey @emmtre ,

Does not belong in this thread here, but I would be interested in the experience with WP Migrate. I use Spinup WP with two servers and could also get used to it for development.

So far I use Wordmove ( for synchronization. Unfortunately, because it’s Ruby based, it always requires a local installation to be involved as a middleman. I’ve been on the verge of buying WP Migrate many times, but I’d love to hear about any experiences with it (gladly in a PM).

I ran local application as administrator on Windows and it worked okay with 6.31 was after having the same problem with previous versions. So perhaps the batch file that runs the “Trust certificate” script is being blocked by anti-virus or window defender? Sorry I don’t know enough to suggest anything better.

I’m having issues trusting my SSL within macOS Monterey. I’ve tried following the steps detailed here ( and am able to trust the site, but it does not transfer into Local. I continue to get a ‘Heads Up. We ran into an issue trusting the Local SSL certificate’ error even though I’ve adjusted to ‘Always Trust’ in my Keychain Access.


I haven’t seen a fix yet, but appears to be a similar issue as what’s discussed in this thread.

I’m getting this issue now too.

Start new site and can’t Trust the SSL

same here :frowning_face: only in Firefox

Hi all - I am going to merge this topic with the larger thread on the issue so that we can keep discussion in the same place. Still working on this one!

1 Like

Also seeing this issue and it’s quite frustrating. For me the site does not display with SSL. Says it is insecure.

So is this still not fixed in 6.4??

Same issue in 6.4.0+5927 with macOS Monterey 12.3.1 but works on macOS Big Sur on other mbp

1 Like

additional information to add to the thread.

I had this issue back in 6.3.0 and either an update resolved it or I somehow did a complete reinstall to fix - I can’t remember at this point.

Now in version 6.4.0+5927 it randomly popped up again after having been fine even with this version for a bit.

It doesn’t indicate any issues in the browser, but I am encountering an issue with TCPDF not being able to load an image into a pdf because it errors - most likely due to trying to load the image via https

I have since changed today to load the images via the base upload dir path instead of base url to fix it but thought it relevant to share.

Still having the same issue on Windows 11 build 6.4.0+5927

Any progress on this? Local has become useless for me as I can’t add a new site (hosts can’t be written, manual edit doesn’t help) and the certificates are borking (one site still works, the other has no cert and hitting the trust button doesn’t create anything, at least nothing Keychain sees. (Mac Monterey, 6.4.0)


@austinwendt can you please update on an ETA on a fix for this? It makes Local pretty useless.

Hello - this bug fix is dev complete, and we’re starting QA testing with the build. It will be included the next release of Local.

I want to be clear - this thread (and associated fix) is only for the UI bug of Local displaying a site as untrusted when it is in fact trusted when opened in the browser. The bug addressed here is not anything functional.

Can @Glark or @arecian expand on what “useless” means? I want to make sure we’re not conflating different issues here.

Good to hear the SSL issue is going to be fixed. I mostly use Local to work locally in WP (working on the content of the site, not dev stuff per se) and magic update it to FW.

The SSL thing meant having to use localhost which didn’t work for that flow due to http vs https and the hosts file issue I referred to I mentioned because it’s the other big thing that simply roadblocks new sites in Local. I cannot create a functional new site in Local because the hosts file is on lock down as far as Local is concerned.

There’s topics on it like this one: Can't Update Hosts File in Monterey! - #11 by miacevedo but discussion seems to have died on the vine.

Feels like new Mac security measures are fighting with Local. That’s what I meant, I can’t use Local for new sites and long standing existing sites are doing the SSL complaints.

I know it is not universal. I could export a site to my laptop’s Local and work on it from there (with the SSL issues though). Anyways, I’m about to update to a Mac Studio so I’m not going to do a restore and hopefully Local will work like it used to there.

For me, I can hit the Trust button, nothing happens and the browser does not display it as secure. The ONLY way I can get it to display as secure is to manually edit the site in the keychain and select “always trust” manually. Which is quite tedious when you have to do this for each site you create.

And then Local still displays the banner:

after @Glark linked to the other issue relating to not being able to update the host file, that got me thinking that the day before I had this issue again is when macOS 12.4 update came out. Very likely related to that update somehow.

/etc/hosts has these permissions and ownership:
-rw-r–r-- 1 root wheel

On Chrome Version 102.0.5005.61 (Official Build) (arm64) / macOS Version 12.4 I can no longer access my sites admin area due to NET::ERR_CERT_INVALID. It previously worked fine after manually trusting certificates. I ignored the warnings. On Safari the sites work fine as it seems that, unlike Chrome, it still trusts the certificates.

I just updated to 6.4.0, and now my certificates aren’t trusted and I can’t access my sites in Chrome. I can use them in Firefox. In Chrome, I get NET::ERR_CERT_INVALID errors. If I click the “Trust” button in Local, the system prompts me for my password, but nothing else happens.