"TypeError: phpPorts" when starting site on Windows

I clicked on the auto update to upgrade local to 5.4.1, I originally had the issue with local not starting after the update. I tried all the suggestion using 5.0.6 / 5.0.5 installer. Now I get a TypeError: phpPorts issue
have included a screenshot and log

local-lightning.log (156.0 KB)

Just an update that the database port keeps hanging so no port is returned. I tried cloning the site which had the original issue and this is a screenshot of the database with no port.

Hi @juff1,

Sorry for the trouble! This is an issue we’re actively looking into and we have a fix queued up for the next Local/Local Beta release.

See "Uh-oh! Unable to start site" on macOS with Local 5.4.1 - #9 by clay - Support - Local Community for more details.

In the meantime, you might be able to get up and running again by Cloning the site. See below:

Thanks for the reply @clay unfortunately and clone of the site didn’t work, and I had to uninstall Local removed all traces of it being installed including sites and started working on a brand new install.

Bummer! Glad to hear the new site works.

For what it’s worth, Local 5.4.2 includes a guard against the ports object being empty and should auto-fix this.

This topic was automatically closed 12 hours after the last reply. New replies are no longer allowed.