[Log included] Server no longer starts after an attempted upgrade of PHP

local-lightning.log (86.6 KB)

I did a PHP upgrade and error appeared. Site is no longer accessible due to the server unable to start. Neither a rollback of this mentioned PHP update is allowed since a perpetual loading bar is in place of many of the settings. Screenshot attached.

A look at the log reveals the following cause.

TypeError: Cannot read property 'socket' of null

A complete closure, through Task Manager and a restart did not solve the issue. @rowatt suggested in this post. I quote:

  • move the site files to a new location
  • delete the site in Local
  • recreate the site in Local, stop the site
  • replace the app directory in the new site with the app directory from the old site files
  • restart the site in Local
  • import the DB

However, this seems to assume that export of the database is possible which isn’t the case. No progress has been made to follow the steps from @rowatt since the final step is not possible. File export is also not possible as the option is greyed out. The only possible option in the right click menu, Clone, also returned the same error.

It seems that the problem can only be solved if there’s a way to export the database without having the server up. Is there anyone who knows how to do this?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.