Uh-oh! Could not update hosts file, Please help

I’ve followed the instructions in this post with no luck. Fix Local

I’ve made sure my antivirus is not blocking anything. I use Bitdefender Build

I’ve tried uninstalling and reinstalling 3 different times following these directions

What issue or error are you experiencing?

Can’t update hosts file

Local Error

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

System Details

  • Local Version:

Version 8.1.0+6514

  • Operating System (OS) and OS version:

Windows 10 Build: 19045.3693

Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)

local-logs.zip (5.3 KB)

Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @Kentos

If you’re using Bitdefender it seems like users are often running into Host File issues checking a quick search here. You might look through their forums and see if some of the recommendations and workarounds help.

1 Like

Thanks for the suggestion, I’ve tried looking through those docs, but I don’t think the issue is with Bitdefender. I uninstalled it, and Local still has the same issue.

I made another user account on my computer and installed Local on that account, and it mostly fixed the issue, but it then started getting the following error. (The account has admin privileges)

New Error

Any suggestions?

I’m really hoping to avoid doing a fresh install of Windows 10. :frowning:

I’ve started getting this error message as well.

Local Install Error

Additional update, I was able to successfully create a site using the Atlas plugin. However when I go to star the sight it gives me an error message “Heads-up! Local’s router is having trouble starting. Learn more” Which takes me to this page. Router

I’ve tried following those instructions and changing the router to Local Host, however this is what I get when I try and “Open site”

With all of this said, even if I get this working, I’d still like to be able to make a site from scratch without the plugin.

Hello there @Kentos!

It looks like this error may be due to a special character in your Windows username.

Can you try creating and using a user directory without extended characters?



Thanks for the reply! I’ve previously tried doing that, I made another account called local. When I tried installing Local and creating a new website it worked, however when I tried to start it I got the following error.

New Error

I deleted that user account as it wasn’t working properly, and just barley made a new one to try it out again, this time under the name WordPress Local and I got the following error when I tried to create a new site after installing Local.

Error Installing WordPress

Here are the logs from that.

local-logs (1).zip (4.0 KB)

Additionally when I installed Local and it asked if I wanted it to be usable by everyone on the computer or just for that account, I chose just that account. (I technically have two installs on my computer right now, one for my Kent’s PC account, and one for the one I just made WordPress Local, both of which when installing I chose the option to have it only available for that user account.)

Spaces in the username may also cause problems.


Thanks! I tried making another user account called wordpress, this time I installed local (again just for that user account) and made a new site. No errors. However when I start the site, and try to open it up I get a 404

Here are the logs.

local-logs (2).zip (6.7 KB)

Hi @Kentos

I’ve responded to your WPE support ticket. To avoid double comms/work we’ll keep our follow up with you there. Once we’ve narrowed down a fix/solution we can update this thread for others who may run into similar issues.


Hey Nick,

I’ve responded on the support ticket but wanted to update this thread as well.

I ended up just wiping my entire machine, and reinstalling Windows 10 (I made sure that the computer name didn’t have any special characters). Local seems to be working perfectly fine now. I’ve reinstalled most of my apps, and none of them have caused any issues, so I’m at a loss as to what was causing the issue. One thing I did notice, is after the fresh install of Windows 10 when I would create or delete a site, I started getting the request in the attached image from my machine, (which I didn’t get on the old install)

I’m guessing this is what was causing the issue, but why I didn’t get this prompt on the previous install I don’t know. Either way I appreciate everyone’s help on this!



I have found the solution for this issue.
Download the hosts files for windows, here you can find how to do it and edit in notepad.
For me it has worked.


Thank you for the follow up here @Kentos! Thank you also for your note here @websitemaker hopefully that will help others as well. :green_heart:

1 Like