Unable to connect to Database (PHP error / Windows 10 / Local v:5.2.5+2498)

Just installed Local today.
Created my first site.

It appears there may be a port mismatch.
Adminer works fine, on port: 10006.
But php.ini reports Mysqli on port 3306 (standard port).

Wordpress is failing to load, unable to connect with the DB.
I did not change any settings in wp-config initially.
Then I tried changing the port there (not even sure that is viable, as it should be pulling from mysqli/php.ini)

Attempted to override the port setting in the php.ini.hbs (handlebars file), but that seems to have no effect.

Not sure where to look next?
(I did look into the app under appdata, and looked at the logs. But nothing obvious to adjust.)

I double checked my phpinfo and realised I was picking up an additional ini file from a different php installation elsewhere. Disabled that and returned the php.ini.hbs file to its original settings and now everything seems to be working.

Sigh, :slight_smile:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.