Unable to open Local App on my Mac

What issue or error are you experiencing?

Unable to open Local App on my Mac. Nothing happens after clicking on open. I’ve already reinstalled app.

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc


System Details

  • Local Version:
    Version 8.1.0 (8.1.0.20231107.1)
  • Operating System (OS) and OS version:
    Big Sur 11.7.8

Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)


Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @Yuliia

Have you tried any reboots of your machine?

Do you have any antivirus, security, or firewall applications that could be blocking Local?

Are you running other developer applications simultaneously?

no, not really

Just to double check please try the steps below:

but what about the files? I don’t have any backups

Sorry I assumed you didn’t have any sites since you couldn’t get in. Were you able to access Local in the past and then suddenly it stopped?

You should be able to locate any site files manually, and save copies of those for re-import later.

The article is not helpful, I’m not able to open Local app. Nothing happens after clicking on icon. It looks like it is running but impossible to open. Could you please contact me with someone who will be able to figure out what is wrong?

I understand that Local is not opening. Did you have any sites within Local that you needed to save? If so, you should be able to locate those site files manually on your machine without opening Local and save copies. If you never worked on any sites in Local in the past then that’s not a concern, you can just go through the steps to uninstall Local and try reinstalling it and rebooting.

On Sunday it worked. I have no idea what happened later.

And have you tried rebooting your machine since then? Or completely shutting it down and starting it back up?

Again on this article that I shared:

If you go to the section Restore from only Local site files it should help show you how you can find your site files on your machine to save them.

Something specific to your machine is blocking Local from opening, but it’s hard for us to say what. This way you can at least make sure your work is saved if you need to completely uninstall/reinstall.

I guess I don’t fully understand what ‘rebooting your machine’ means

And btw, I don’t use either Flywheel or WP Engine on Local

Rebooting your machine = Starting your computer

Or doing a full shut down/turn off and booting it back up.

It’s not necessary to host with Flywheel or WP Engine to use Local. It’s free to the entire WordPress community.

Oh, yeah I did that immediately after Local didn’t fully open.

Is it possible to restore all existing files and sites? I can’t create a site with the same name because it says that such a website has existing local data.

So were you able to get back into your Local app?

If you copy/save your site files, then you can delete the site in Local and reimport the site using the steps on the link I shared above. Then you can use the same name if you want.

If you’re experiencing issues with the Local app on your Mac where nothing happens after clicking “Open,” there could be various reasons behind this behavior. Here are some steps you can take to troubleshoot and resolve the issue:

  1. Check for Running Processes:
  • Open the Activity Monitor (Applications > Utilities > Activity Monitor).
  • Look for any processes related to Local or the previous installation.
  • If you find any, select them and click the “X” button to force quit.
  1. Reboot Your Mac:
  • Sometimes, simply restarting your computer can resolve unexpected issues.
  1. Check for Updates:
  • Make sure that both your operating system and the Local app are up to date.
  1. Check for Console Errors:
  • Open the Console app (Applications > Utilities > Console) and look for any error messages related to Local when you try to open it.
  1. Permissions:
  • Check the permissions for the Local app. Right-click on the app, choose “Get Info,” and make sure your user account has the necessary permissions.

If nothing works, try uninstall it and reinstall the latest version.

1 Like

Thank you for those helpful steps @TerryGrey! We also have a guide below on uninstalling Local that some might find useful if they are attempting to completely wipe it and start fresh.