Local app open but not running

What issue or error are you experiencing?

I was prompted to update Local today, and after attempting to do so the update failed. I closed the app, and since then I can not get it to open correctly. The app looks as if it should be running, I can see it open when looking at my dock and also in the upper left hand window of my Mac, but there is no window and the app doesn’t actually seem to be running. I’ve tried restarting, shutting down, and even installing a new instance of the app but nothing has worked.

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

Screen Shot 2024-05-09 at 2.32.00 PM
Screen Shot 2024-05-09 at 2.32.27 PM

System Details

  • Local Version:
  • Operating System (OS) and OS version:
    Monterey 12.4

Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)

Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @caseymacleod22

When you uninstalled Local did you go through the steps here?

Make sure you have any site files saved or the sites backed up somewhere in case you need to retain that work.

Thank you @Nick-B, this did the trick! I still have all of original sites within in Local Sites directory, is there a good way to go about importing those into the new Local instance?

You should be able to just zip those files back together and re-import them into Local! Similar to the steps here:

Perfect, thank you for your help!


Yep! I’ll close this out for now but don’t hesitate to come back if you have any other questions or concerns.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.