Unable to provision site on a freshly installed macOS

Bug Summary

After installing Local on a freshly set up Mac I am not able to provision any sites.

Steps to reproduce

  • Install macOS Ventura (13.2)
  • Install Local (6.6.1+6281) for ARM processors
  • Provision a new site

Environment Info

  • MacBook Pro (14", 2021)
  • Apple M1 Pro
  • 32 GB RAM
  • macOS Ventura 13.2 (22D49)

Supporting info

Screencast: https://cln.sh/Rx9fmcZW

Hi there @aslotta -

Thank you for the video that was really helpful.

I noticed you received an error about the hosts file - often times that is due to a permissions issue.

Have you had a chance to review this thread?

Let me know!

Sam

@sambrockway - I cannot find a solution on the link you provided.

Hi there @jamestharpe - :wave:

I would encourage you to post a new thread with your issue and your specific setup so we can help you troubleshoot!

Thank you :green_heart:

Sam

Hello there, I am having exactly the same error message as per this thread here, so I cannot provision new sites or import existing ones.

Unfortunately, I could not find a way to open my own thread, so I am following up this one.
My setup is

  • Macbook Air with M2 chip, Ventura 13.4.1
  • Local WP v7.1.0.

I no longer have the issue about editing the hosts file, as I followed the instruction as per thread you attached. But the “Uh-oh! Unable to provision site” message is still there, with the same details as per the original picture posted.

Thank you.

Hi @nuwebstudio - Being on an M2 machine, I assume you’re running the Apple Silicon version of Local?

Some of the binaries that ship with Local still require Rosetta 2 to function; do you have Rosetta installed on your machine? If not, it should be as simple as launching a Terminal window and running softwareupdate --install-rosetta and you should be good to go.

1 Like

Thank you for your reply. Because I installed the Apple silicon version of Local, did not imagine I needed Rosetta. I followed your instructions and now it works, thank you so much!

1 Like

+1, definitely an unfortunate limitation that we’re working to resolve! In the meantime, I’m glad that fixes it up easily. :slight_smile: Happy building!

1 Like

Thank you so much for this tip, i recently just bought a macpro with m2pro sillicon chip and i got stuck for hours searching on how to resolve that bug, huge thanks man you saved my day litteraly

2 Likes

@rosmis you bet, I’m happy it helped! And thanks for using Local, welcome to the community :slight_smile: Let us know if you have other questions!

Hey man thanks a lot this was driving me crazy… I took your advice with the terminal… now everything is up and running… I greatly appreciate it :+1:t5:

2 Likes

Glad that got you fixed up @Rasd! Happy Developing :green_heart: