MacOS Ventura Local Can't Update Hosts File

Issue Summary

I did a fresh installation of Local (Silicon vesrion) on MacOS Ventura, and can’t get it to work. I can’t create a new site as the app can’t modify the hosts file. When I click on the Local notification that requires permissions nothing happens.

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?
    Local can’t create a new site.

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?


To replicate, install Local by Flywheel Apple Silicon Version 6.7.1+6369 on MacOS Ventura 13.3.1 and try to create a new site.

System Details

  • Which version of Local is being used?
    Flywheel Apple Silicon Version 6.7.1+6369

  • What Operating System (OS) and OS version is being used?
    MacOS Ventura 13.3.1

local-lightning.log (11.5 KB)

I’m having this exact problem. Same system specs, same error messages, same logs.

I’ve been through a bunch of the support topics on this. I’ve adjusted the permissions of my hosts file, cleared the DNS cache, even manually entered the hosts entries that Local wants to create, but nothing has worked.

Also running into this issue. This is my log.

local-lightning.log (1.1 KB)

@jojawhi @stefantsv This post by @rodrigomantoan resolved the issue for me. However I only needed to backdate node to 14.20.1 via nvm.

That’s interesting to know. Do you happen to have Rosetta installed? For some users, just installing Rosseta 2 fixed their issue.

Hey @zulu, thanks for your reply and the link to that post. I just tried your solution. I installed Node 14.20.1 via nvm (already had nvm installed), but it still didn’t work. I then tried installing Rosetta 2 via the command line as in the linked post, and I am now able to pull my site to my machine. Downloading the files now. I’m not sure if it was only Rosetta 2 that solved it or if it was the combination of the Node version and Rosetta 2. Will try pulling the site again with a different Node version later.

Howdy y’all, just an FYI that Rosetta 2 is required for Local’s Apple Silicon build due to the Nginx and MySQL Lighting Services compiled on the Intel architecture. We’re working on getting this updated in a future release.

1 Like

My bad. Reading back my message, I realise it reads as if I only backdated node & didn’t install Rosetta 2. Rosetta 2 is required to get local running. Glad you managed to get things working :slightly_smiling_face:

It would probably be helpful for this requirement to be listed on the download page for Local, when downloading the Apple Silicon variant.

1 Like

Thank you for that feedback, @zulu - I’ll pass that along to the Local team!


@stefantsv -

Were you able to get this issue resolved according to the resource @Nick-B shared?



1 Like

Hi there guys was getting the same issue. I have installed rosetta 2 and it works!!! Mac miniM2 [ Macos Ventura 13.2.1 ]and Local 6.7.2.


Thanks for letting us know @nik_dev! Glad it’s all working for you :slight_smile:


I’m having this probably as described in the OP. After unpacking a 40 GB ZIP file, the app bailed. (So, each time I test a solution, I’ll have to unzip it each time…)
Rosetta 2 is installed and I don’t understand how Local could run on my M1 without it.
What am I missing?

Hi @danorton - thanks for using Local. I’m not sure if this is the same issue, but we can dig in.

Are you able to create brand new sites in Local (not importing)? Is Local able to succesfully create the site? You can share your Local logs with us too and we can get a better idea of what is happening. Here is a link to finding those - Retrieve Local’s Log File - Local

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.