Unable to provision Wordpress install on MacOS High Sierra 10.13.6

What issue or error are you experiencing?

Unable to finish a new site installation. Error is thrown declaring local will only run on Mac OS 11.0?

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

Create new site. Never fully completes task.

System Details

  • Local Version:

  • Operating System (OS) and OS version:
    MacOS 10.13.6 High Sierra

Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)
local-logs.zip (19.3 KB)

Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

I assume I need to roll back my version of LocalWP? I stumbled on a note on the website that said anything after 6.5 no longer works with High Sierra, is this correct? Should I downgrade to 6.5?

Tried downgrading to local 6.5.1 and was able to successfully install a site but only with php version 7.3.5. I cannot seem to install any higher versions without Wordpress failing to load frustratingly.

If I could upgrade my OS I would but I do not have the luxury of purchasing a newer Mac at the moment. I am currently running macOS High Sierra on a mid-2011 iMac.

Is there no workaround for this? It’s a serious bummer.

Hi @hbpschico

You are correct in that it’s tied to your OS version. You can still use Local, but you won’t be able to use the latest versions of PHP for example. More details below:

Thank you @Nick-B

May I ask, since normally in the past when developing themes I never used a tool like this and had to do it all manually on the backend… does it matter what php version I technically choose to “design” my site in in Local? Can I simply change this on my server later? And if so, what would be entailed in order to upgrade my php version later server side?

Unfortunately, it could be pretty jarring to jump PHP versions depending on the configuration of your site. I’ve seen many sites go down or look completely broken because a theme or plugin was not compatible with a PHP update. Something I would encourage you to do once you have the site in a ready state on Local is to get it moved to a host with an updated PHP version so you can do a QA on it first. I would do this before adding domains and pointing DNS so that the site isn’t getting any live traffic yet. For example, on Flywheel you can get a free 14-day Demo.

Demo Site

But no matter what host you go to you should be able to use a temporary domain and/or put the site in privacy mode so that it’s not publicly visible while you do your final checks.

1 Like

Darn… I suppose it’s arbitrary at this point, but what is the conflict not allowing later versions of php to be utilized properly on older Mac OS’s?

It mostly has to do with all the changes to the shared libraries that MacOS has. PHP is expecting certain aspects of the OS to be there and they aren’t there, which causes PHP to generate an error.


@ben.turner i presume there is no workaround for this then

Unfortunately not with Local. The main options at this point are:

  1. Upgrade to a more recent version of MacOS.
  2. Try and compile the newer versions of PHP on the system yourself.
1 Like

Thank you @ben.turner

Figured I’d take a stab at using it as is then, but already encountered an issue — I can’t seem to edit in the customize page, or add new pages or posts in Wordpress. It just goes blank. Is this due to the php version?

Seems to happen in the stock theme, or any other theme. Have not added any plugins yet.

Receiving this error in my debug.log

[08-Aug-2023 22:03:56 UTC] PHP Warning: mysqli_real_connect(): (HY000/2002): No such file or directory in /Users/myname/Local Sites/earthsteal/app/public/wp-includes/class-wpdb.php on line 2035

Here is an example of what’s happening

Error is occurring in versions as old as Local 6.0 running php 7.3.5. Same result in Local 7.1.2 running php 7.3.5. App lets me effectively setup a site, launch it, and also enter the dashboard… but as soon as I attempt to edit anything the pages go blank.

Brower is Safari v13.1.2

I guess I led myself down a necessary troubleshooting rabbit hole because it dawned on me I should attempt to try this on another browser and I was able to load the pages for customizing or new pages etc. Very odd Safari seems to be partially to blame here. It is admittedly a very old build.

Hi @hbpschico

Sorry for the delay in response but we’re glad to see you were able to get things working again! Sometimes browsers can be pesky and it’s necessary to have 2 or 3 different ones to be able to spot check in.

@Nick-B thank you, it’s been years since I’ve done any programming or web design so I’m a bit rusty!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.