Unable to push site due to file permissions on media

Hi, thank you. Anyway I’ve just installed the update, I push my website and I have another error. I attach the log.
local-lightning.log (86.2 KB)

Hey @sanetti

Looking at the Local log, it looks like there are a number of images that have permissions that prevent Local from pushing them. The images all look something like:

/cygdrive/c/Users/user/Local Sites/<site-name>/app/public/wp-content/uploads/2024/05/<image-name>.jpg

I’d recommend opening that folder and examining the file permissions for those images in case there is something set on them that would prevent Local from pushing them remotely.

Thank you for the answer. I tried to open the folder and check their permissions but they are normal as the old files in the folder that I’ve already pushed.

Hi @sanetti

Can you try these steps?

  • Locate the site files on your machine, and save a copy of them to your desktop. If you click Go to Site Folder under your site name it should take you right to where they are located.
  • Once you have those copied, completely delete the site from Local
  • Make sure your regular Local app is updated to the latest release 9.0.3 Releases - Local
  • After updating, quit and restart Local
  • Reimport the site back into Local. You can refer here on how to Restore from only Local site files
    *Attempt the push again and if you still have trouble share an updated Local log with us.

Hey @sanetti – I split these replies to their own topic so that we can focus on getting Connect working for you!