Using Git: "fatal: write error: Permission denied" in /app folder

After the most recent LBF upgrade, I can no-longer use Git as I once was before. Before I had installed it using apt-get update && apt-get install git and was able to clone repos into /app/public directories. Now, after the upgrade, I can no longer clone into any folder in the app/ directory. I can, however, clone anywhere else, e.g. $HOME or in the root /. I get the message:

fatal: write error: Permission denied

…when trying to clone now, and I’m not sure why. I have tried:

  • Deleting the site, starting over, and trying again
  • Tanked my VM (and Local data) and started over, and trying again

I’m not sure about a) what I can do, and b) what might have changed to cause this to happen.

Hey @aubreypwd,

It looks like there may be an issue with cloning and Faster Docker Volumes v2. I know this isn’t ideal, but disabling Faster Docker Volumes will fix the issue.

Is there something keeping you from using git on your Mac or PC instead of inside the site container? You shouldn’t have any issues if you go that route.

Thanks for the super-fast reply! Doing that helped, and fixed the issue. The reason I needed to run Git on the container’s end was because part of our script runs Git commands when executed, using the version of Git I installed (it obviously doesn’t run the version of Git on the host).

Seems I just ran into this bug. Disabling Faster Docker Volumes fixed it for me. Thanks