Using Symlinks with local

Okay so with the preface that I much prefer the user experience of Local to MAMP Pro…


I have unlimited amazon cloud drive, and I keep everything backed up from my local machine there using a sync system called odrive.

With MAMP Pro, I could cut and paste the wordpress install folders from htdocs to the sync folder, then create a symlink to them in the htdocs.

This worked great, MAMP didn’t care that it was accessing the installs through the symlink.

I tried this with Local. At first it was okay, but when I close and reopen Local I get an error to do with TLS certificates and then it hangs trying to repeatedly reload system image or something.

Problem is, that even when I try to copy the original folder back into place in the local sites folder, the error persists.

Is there anyway to change the destination for the local sites folder? I would love for that folder to be in my Sync folder then I could symlink that into my home folder.



1 Like

Hey Jeff,

Symlinks that link outside of the shared Virtualbox folder are not supported by Virtualbox.

Fortunately, there’s an addon that should do exactly what you’re wanting :slight_smile:

Check out

1 Like

Hey Clay,

That’s great news, I’ll check it out now.

Nice one

Just wanted to say, the Add-on seems superb, exactly what I needed.

Just remapped a volume into my sync folder, then symlinked into my home folder. Brilliant.

I had to regenerate Docker Machine TLS certificates after I installed the add-on, and also upon restarting for the first 2 restarts after remapping volumes. Now it starts local machine immediately upon starting up.

I only tried with a test volume. I have duplicates of all my sites, so I’m going to try remapping real dev sites one by one and checking the TLS thing. I’ll feedback more after.

Great work Clay!

Remapped volumes for 8 sites. No longer getting the TLS issue at startup, all good.


edit - after deleting original folders, I got this issue again, after restarting a few times it went away. Things are working okay, but there is a warning that ‘WordPress does not exist in this directory’ - ie the app is reading the local sitepath and not the mapped sitepath.

Thanks. This worked perfectly (no TLS issues) as a workaround for a symlink to an under-development theme in my repos directory.

1 Like

Is it possible to map your uploads folder to an external hard drive?

I had symlinks setup that did this before using Local and now the mapping is just giving me a 404 error (was 403 Forbidden before mapping and using addon so that’s a plus).

It’s as if the new map isn’t actually working…

Any ideas? Really need to save space on my actual computer.

It should be!

Do you have Faster Docker Volumes enabled under Preferences » Advanced?

Yes, it is enabled.

Running the current setup in volumes for the site:

Host Source: /Users/jrglass/Sites/snowboardmag/app/public/wp-content/uploads
Container Destination: /Volumes/External/sites/snowboard/uploads

Does that setup work or am I missing something?

1 Like

Hi @jglass,

Have you found a solution?
I have the same problem when I want to install on my external hard drive.

Thanks !

No solution yet.

@clay, do we need to also setup an actual symlink after we setup Local correctly, or is no actual symlink needed as Local handles that?

@autour @jglass,

Is Faster Docker Volumes disabled?

If not, you both may want to try disabling Faster Docker Volumes. Then, go to Help » Restart Local Machine.

No symlink is needed :slight_smile:

Yup, that did the trick. Thanks for the help @clay!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.