Run site from an external or network drive?

I’m trying to keep a site in sync between two computers (iMac and MacBook Pro), so I’m wanting to use the network drive created by using Google File Stream.

I referenced Using Symlinks with local and Sites on external drive – error installing WordPress

Here are my screenshots:,

I then went to Preferences » Advanced and disabled then re-enabled “Faster Docker Volumes” and now see this:

Please advise. tyvm!

P.S. Once working on this computer, how can I “import”/inherit it on the other computer (i.e. from existing files)?

1 Like

Update: when I went to stop the site, I got this error:

Uh-oh! Local ran into an issue while backing up tribe’s database to the site’s “app/sql” directory.
Please check the local-by-flywheel.log file for more details.

Here’s my log file containing all of today’s records: 2018-02-14-local-by-flywheel

That looks like it’s a mount/volume error.

Please try going to Help » Restart Local’s Machine to reinitiate the VM and mounts.

Sorry I know there are multiple moving pieces here.

I did what you suggested but symlinks still don’t work. Was it supposed to fix that or make it possible to run this on a network-mounted drive?

Symlinks won’t work with Local. It’s simply a VirtualBox limitation.

The volumes add-on will allow you to map specific directories in the Local site’s container to your network drive.

Gotcha. Thanks for the clarification.

If I get this working on Mac1, how do I “import”/inherit this site on Mac2 so the files and such stay in sync?

@clay could you please explain/demonstrate exactly what I need to do to have my files (also my database?) on my network drive?

I saw this comment from Using Symlinks with local - #4 by jeffcleverley - Support - Local Community

But then I didn’t know which things to do here: Image 2018-02-15 at 10.30.4...

And he mentioned symlink, but you said that doesn’t work.

Thanks for the help.

@clay just checking back.

I moved all my files from /Users/cmp/Local Sites/tribe/app/public to /Volumes/GoogleDrive/My Drive/_everything/cmp/Local Sites/tribe

Then I mapped this as best I could guess:

But then my domain just loaded nothingness (apache file directory, which was blank)

Please assist. Thank you.


That looks good!

Can you provide more details on this? Does it never load or does it load with a white screen?

Also, can you provide the log files in the site’s /logs directory?

Here’s a video of me replicating the issue just now:
And here’s my log file from yesterday and today (collected after doing that video):

Additionally, once I get it working, can I run the database on remote or is it only advisable/okay to put the files there?

Thank you so much.

I tried Dropbox instead and it gives 403 Forbidden.

I pointed /Users/cmp/Local Sites/tribe/app
to /Users/cmp/Dropbox/local-sites/tribe/app

You don’t have permission to access / on this server.