Warning: An unexpected error occurred

Warning: An unexpected error occurred. Something may be wrong with WordPress.org or this server’s configuration. If you continue to have problems, please try the support forums. (WordPress could not establish a secure connection to WordPress.org. Please contact your server administrator.) in /app/public/wp-includes/update.php on line 319

Why this happen to me when I upload new plugin? Please check this screenshot http://nimb.ws/mK9WPz

This is a fairly standard message if you’re having issues connecting to dot org. It will go away.

So you say I just ignore it?

Yes, ignore it.

1 Like

One more thing you can try is going to Help » Restart Local’s Machine to reset the VirtualBox network device.

I did what you suggest. But, the problem remains the same!

Just to be clear. You see this error but no functional issue. Sometimes just has to do with your network connection. Use Query Monitor and these debug notices move off the page into a menu.

No problem, I’ll just ignore it as it is not a problem, just a false message. Thanks for your reply.

I’m getting the same error, only it is definitely having an impact on functionality. When I try to install a new plugin, it give me this error and tells me I’m unable to install the plugin. Only started happening after I upgraded to the new version.

Hi all,

Sorry for the trouble!

If anyone is having this issue, please reply with the answers to these questions to speed up the process of finding what’s causing this!

  1. Is this happening on all of your sites?
  2. What is the environment for the site (if multiple, provide details if they’re different) this is happening on? Preferred vs. Custom, etc.
  3. What operating system are you seeing this on?

1 > Sometimes all of the site sometimes work like normal for all of the sites. So, this is not always happening.
2 > Single site, I think it was on custom PHP version.
3 > I’m using Mac operating system.

Hey guys, I have the same issue. Tried reinstalling/changing php versions etc. but nothing helps.

  1. It is happening on all the test websites I created. (The WP dashboard also loads very slow)
  2. It happens on the default and custom environments I tested.
  3. I’m using a MacBook Pro (Retina, 15-inch, Mid 2015) OS version 10.12.6

Hi all,

Here’s another thing you can try:

  1. Quit Local if it’s running
  2. Open Terminal
  3. Run /Applications/Local\ by\ Flywheel.app/Contents/Resources/extraResources/virtual-machine/vendor/docker/osx/docker-machine stop local-by-flywheel
  4. Run VBoxManage modifyvm local-by-flywheel --natdnshostresolver1 on
  5. Run VBoxManage modifyvm local-by-flywheel --natdnsproxy1 on
  6. Re-open Local and check the site

If you run into more issues after running these commands, you can repeat the steps but change the on values to off.


As far as speed goes, do you have Faster Docker Volumes enabled? You can check by going to Preferences » Advanced.

If it is, there might be a slow external request. The steps above might help, but if they don’t I would try the Airplane Mode plugin and see if blocking outbound requests fixes the speed issue.

Hey Clay. Thanks for your response! I re-downloaded flywheel local, did a new clean install today and the problem seems to be gone! The dashboard loads fast and I can add plugins etc. without issues.

Currently using php 5.6.2 and MySQL 5.5.55. If it comes back somehow Ill try your suggestions and post a need update.

1 Like

Thank you very much Clay, the Terminal trick seems to work fine!

For those that had Pressmatic before Local: in the terminal commands, make sure you write pressmatic instead of local-by-fleewheel.

Hi everyone,
I’m having the same issue but i’m using wondows 10, can I use the same trick ?

Hi Marie,

Yup! Please see the following FAQ for the Windows commands: Help! My Local site cannot establish a connection to WordPress.org

I only have one site, I’m running Windows 10 and Chrome is my browser.

Hi Jennifer,

Are you seeing the warning that Mohsin mentioned? If not, can you describe the problem you’re experiencing?

I was having the same issue – the wordpress dashboard was loading slowly and I was unable to install plugins on any of my sites on Local. Can confirm that these commands fixed it :slight_smile:

1 Like