Where are PHP executables stored?

I’m running the latest FlyWheel 2.0.1 and wondering where exactly are php executables stored; and how do I access them? I need the information in order to configure phpStorm with Local.

1 Like

Guys, I’ve already lost a full day of work because of this upgrade. Can someone tell me how do I configure the PHP interpreter with this new system?

The PHP executables are in the site containers and are only compiled for Linux. They weren’t moved from previous versions of Local.

What are you needing the path for?

I’m not sure what’s happening, and how is this supposed to work. I created a new project in phpStorm and it asked me to configure php. It kept asking for php install path (interpreter). I still have CLI interpreter set to and there’s no xdebug path shown. Yet, xDebug works as expected. Totally clueless here.

While my problem is solved; I’m curious to know why is this working.

The PHP interpreter is for executing PHP inside PhpStorm as well as executing PHP in the browser preview. Also I believe it’s used for PHPUnit in PhpStorm but that’s a whole different story.

Xdebug works because it doesn’t require the PHP interpreter in PhpStorm. It’s connecting to Xdebug that’s running inside the Local site container.

1 Like

xDebug now works; but doesn’t show variables on the current page on the top. Instead, it lists them alphabetically. I checked and assured that this isn’t because of any altered phpStorm settings; but incorrect xdebug configuration. I’ve enabled the Local addon that integrates phpStorm with Local; but that hasn’t helped.

Could you tell me how do I configure the interpreter in phpStorm?

I’m following the instructions here - https://www.jetbrains.com/help/phpstorm/configuring-xdebug.html ‘Configuring Xdebug in PhpStorm’. Step 2.1 requires me to choose the PHP installation. Not sure how to go about it.

To use Xdebug with Local all you have to do is click on the button under Utilities to configure IntellIJ + Xdebug and then make app/public your project folder.

Then, you should see a run configuration named Local by Flywheel. If you use that and set breakpoints you should see the variables :smiley:

Yep, I do have the “Local by Flywheel” in the 'servers section. But you can see that the variables just above the breakpoints aren’t listed in the variables section. Earlier, it’d have shown “$get_quiz_id” at the top, instead of the other variables.

Scroll further down the variable listing. Your expected variable doesn’t sort to the top.

That’s what I’m saying. The variables should pop up at the top; like they did in the past.

I did this and I’m not seeing the Local by Flywheel appear in PhpStorm :frowning:


Make sure you’re opening the public folder with PhpStorm and not a specific theme or plugin folder.

1 Like

That was exactly the issue – I was opening a directory and not an application