Windows 10 - Faster Docker Volumes will not stay switched on


Latest Flywheel, Windows 10. One site Apache. Turning on Faster Docker Volumes appears to work but then 30 seconds or so later, it switches itself off.

Looking into the log file, I can see the following (not sure if relevent)

Aug 13, 2018, 10:43 AM GMT+1 - error: [main/docker-machine-fdv] NFS Test Result Error: Command failed: C:\Users\Test User\AppData\Local\Programs\local-by-flywheel\resources\extraResources\virtual-machine\vendor\docker\windows\docker-machine.exe ssh local-by-flywheel sudo timeout -t 4 sh -c "/usr/local/etc/init.d/nfs-client restart && mkdir -p /tmp/nfs-test-H13hzRCHX && mount -t nfs -o udp,nolock,soft,noacl,actimeo=1,async /tmp/nfs-test-H13hzRCHX && [ -d "/tmp/nfs-test-H13hzRCHX/Test User" ] && echo 'success'"
sh: missing ]
exit status 2

    at ChildProcess.exithandler (child_process.js:217:12)
    at emitTwo (events.js:106:13)
    at ChildProcess.emit (events.js:194:7)
    at maybeClose (internal/child_process.js:899:16)
    at Process.ChildProcess._handle.onexit (internal/child_process.js:226:5)

Anyone offer any kind of help please?


Same issue here with 2.3.3 on Windows 10.

I checked the firewall, but it’s not blocking “Local-Flywheel-WinNFSd.exe”.

I edited “true” to “false” directly on “faster-docker-volumes.json”, but it was reverted to “true” in seconds.

I’ve already restarted Win10 many times and re-installed Local twice, but this issue is not solved yet.
WordPress runs incredibly slow.

Hello ,

Have you solved the problem?

Not yet here.
I tried 2.3.4, but the same problem occurs…

I have almost the same problem, I turn on Faster Docker Volumes, there seems to be some process that runs through each of my local sites, then Docker Volumes fails for each site and it’s auto-turned off. Using v2.4.2.

Haven’t tried re-installing from scratch but have tried restarting computer. Seems this is a bug.

I have 2.4.3 installed, and am experiencing the same problem but with Win7. I flip Faster Docker on, and then Flywheel automatically flips it off about 30 seconds later. I am notified with a little popup.

Any assistance is appreciated.

+1, I’m having this precise issue on Windows 10.

Hi all,

If Faster Docker Volumes isn’t staying enabled, then Local’s Faster Docker Volumes server may be getting blocked by the built-in Windows Firewall or a third-party firewall such as Zone Alarm, Kaspersky, etc.

When you first enable Faster Docker Volumes on Windows, you will see a confirmation like the one below. In order for Faster Docker Volumes to work, Local-Flywheel-WinNFSd.exe has to be approved so it can communicate with the virtual machine. In case you don’t approve it there, you can still approve it after the fact.

Approving Local-Flywheel-WinNFSd.exe in the Windows Firewall After the Fact

  1. Open the Windows Start menu and type in “Firewall”. You should see an option that says “Allow an app through Windows Firewall”
  2. Once the window opens, scroll down to local-flywheel-winnfsd.exe
  3. Check the checkmarks beside the arrows in the screenshot below. You may need to click the “Change Settings” button
  4. Once the checkboxes are checked, it should look something like this:
  5. Press OK
  6. Go back to Local and re-enable Faster Docker Volumes

If the issue persists after going through these steps, be sure that you don’t have a third-party also blocking Local-Flywheel-WinNFSd.exe.

1 Like

This seems to have worked for me. However, I have TWO entries for local-flywheel-winnfsd.exe.
Originally, one had Private enabled and the other had Public enabled.
After making them both checked for each of the two entries, I thought that they would merge and only one would show, but I still have two identical entries showing. Not sure why.

Do you think this is OK?

Glad to hear it!

I don’t think it’ll cause any problems by having more than one entry.

If you’re curious and want to remove one, I’d click on the “Details…” button to see where the entries are coming from.

Just checked the entries and they are exact duplicates. So I deleted one.

After launching LOCAL again, it kept showing the blue popup “Faster Docker Volumes - Restarting NFS Server” repeatedly non-stop. I must have screwed something up accidentally… Ugh, seemed like everything had been resolved. I’ll restart the computer and see.

In the meantime, what do you think could be causing this popup to appear/disappear at the rate of 2 times per second?

I have seen this happen but have been unable to reproduce it reliably. I’ll make a note of this.

You may want to remove all of the local-flywheel-winnfsd.exe entries and start fresh. After you do that, you should see the prompt below again.

Thanks, restarting the computer fixed the flickering Faster Docker Volumes popup box issue.
However I noticed the SSL on one or two of the sites was broken.

Is there a relation between the SSL certificate and the firewall / fast docker volumes?

We are still seeing an issue on this.

I successfully changed by Win7 settings so that Local by Flywheel could poke through the firewall. When I start, a Flywheel pop-up message states “Local has successfully disabled faster docker volumes.”

I’ve tried restarting Local by Flywheel, destroying the VM, restarting the machine… same results every time.

Any suggestions?

Hi David,

Are you running any other internet security or firewalls outside of the built-in firewall?

Also, can you please provide your local-by-flywheel.log file? See How do I retrieve Local's log file? for instructions on how to do so.

Hi, Clay. Just messaged the log file to you.


Hi, Clay. Wondering if you were able to deduce anything from the log file I sent over. Any progress?