Wont update to 2.4.2


I just recently updated macOS to Mojave and everything is fine, git, homebrew, Local by Flywheel, everything, I even updated virtual box to the latest version.

The issue is when I try to update to Local by Flywheel to 2.4.2, I go through the update process and then Flywheel tells me to quit Flywheel and that it will install the update and re-launch when it is done, but nothing happens, I tried it twice, restarted macOS each time and I even left it over night hoping that maybe it was doing something in the background, but Local by Flywheel is still showing as version 2.2.4 ??

Any ideas what I can do? I’m trying to avoid having to reinstall the whole thing, I have a lot of client projects in here and I’m a front-end dev, I only just about manage to get by on my limited back-end knowledge when it comes to this sort of thing.


Ok here’s what I did. I had no idea whether this would work but all of my sites were backed up on another laptop so I had nothing to loose. Ready? Open the Applications folder, drag local to the trash, download the latest version of Local and install.

I opened it and all my sites were there, the first time I tried to access one of them I got a 502 gateway error thing, so I restarted MacOS and that solved it.