Local Community

Xdebug + phpstorm ad-on not working

Whenever I try to enable it, I get a popup error: Xdebug + PHPstorm eror the ENOCENT no such file or directory…

Same issue on both Windows 10 install and my MACOS Catalina install.

Any advice?

1 Like

I have the same issue. The error message reads:

Error: ENOENT: no such file or directory, open ‘…\Local Sites…idea\workspace.xml’

I know the workspace file is there and I can open and edit it. This error is thrown by npm from what I can google. When I look at the project folder for the project the .idea\ path only shows php.xml

If you want me to by Local and move my hosting to flywheel, this is not a good start.

1 Like

Same issue here. Xdebug + phpstorm not working. Error: ENOENT: no such file or directory, open ‘…\Local Sites…idea\workspace.xml’.

Hi all,

Sorry for the trouble with the Xdebug + PhpStorm Add-on.

I just tested this using Local 5.2.7 in Windows 10 and was unable to reproduce the issue.

It may be related to the site paths or possibly even your usernames (e.g. username has a special character, apostrophe, etc). If possible, can you all provide the entire error that the Add-on is generating in the log file?

I made it work by doing this:
Copy the “runconfigurations” folder that local creates in the .idea folder in the target filesystem to the phpstorm .idea folder. Run the setup.
Worked for me! YMMV

Hi @gmccord,

Awesome! Glad to hear you figured out a workaround.

Can you elaborate on the above? Specifically what the target filesystem is? I’d love to get to the bottom of this so there isn’t a manual workaround!

I run this on a Mac/Catalina and a Windows 10 system. I think the issue is that my website files are in a different location from the PHPStorm files. For example, on my Mac:
“Local” website files: …/Local Sites/local-website/app/public
PHPStorm files: …/PhpstormProjects/website

The plugin seems to put its files in Local’s folder and it needs to be in PHPStorm’s.

Make sense?


Aha! Thanks for the explanation. I’ll see if I can’t replicate the error with a setup similar to yours.


I’m using Win 10 and the latest LocalWP (5.4.2+3383). For a new site, I’m clicking the “Add run configuration to PHPStorm” and I get the following error:


I see some file been created under “D:\Local\testing\app\public.idea” but definitely not the whole set of them.

My username or path has no special characters. As far as I can see no errors are produced on the error log.

Update Once I manually create the workspace.xml file (an empty file with that name) in that dir, the error message changes


so there must be an issue with the callback creating this file.

Any update on this? This is also broken in 5.5.2. :frowning:

I have found that if I open Finder on my Mac and drag the Sites/mySite/app/public directory down to the app bar and drop it on the PhpStorm icon and open the Local site that way the “Add run configuration to PhpStorm” works for me. Of I drag the root of the website (ie. sites/mySite) then the .idea directory gets created in the mySite directory and it fails to find the workspaces.xml file.

My process:
Create a Custom Wordpress site with Local

Open PhpStorm and create a new project

Point it to the sites/sitename/app/public folder

It will say the the public folder isn’t empty ad ask to create a project from existing files

Say yes and then once the project is created there will be a .idea folder in the public

folder with a workspace.xml file

Now use Local/utilities tab and select ADD RUN CONFIGURATION TO PHPSTORM

The key seems to be that Local only looks for the file in the sitename/app/public/.idea folder so your project needs to be created such that the .idea folder is in the public folder

1 Like

Hi Marshall, fantastic ! thank you very much.

It did the job :slight_smile:

I was searching for nearly 3 hours how to deal with this PHPSTORM+Xdebug configuration issue (that I didn’t have till today, strange)

Thanks again,

Thank you Marshall for this. I have spent the entire night searching for a solution to this problem, and at least I can now see where the problem is. I have followed the steps you outlined and I still get the error shown on the screen. However, when I looked into the .idea folder, I do not see the workspace.xml file.
What could I be missing in this set up?
Thank you,

I have the same problem. I opened the projects in PhpStorm, then click “ADD RUN CONFIGURATION TO PHPSTORM” on Local and gives the error, but I close the project and reopened and now work.

1 Like

Thank you! I finally got it to work but figured out that was not what I originally wanted! I was looking for a way to configure the CLI in phpstorm for Local. I am new to web dev and all of these programs and still trying to wrap my mind around it. I am not trying to obtain the PHP path for the Local PHP install to set up Wordpress…
Thank you,