I cannot get this add-on to install. All it does, whether I install from disk or within the Local app (Windows 10), is sit there forever saying “Installing…”. I’ve tried closing & re-opening Local, closed VS Code, and more - nothing helps. How do I determine what the problem is?


I am also facing same issue tried to install xdebug+vscode addon on linux both from addons page and from disk. It gets stuck and nothing happens. pls help

Thanks for bringing this up @adi3890 and @rhkittredge and welcome to the community!

Can you please provide your Local Log so we can get a better idea of what Local is encountering? See this Community Forum post for instructions on how to do so:

Also, @adi3890 – what distro and version of Linux are you using?

I noticed this issue isn’t isolated to the xdebug add-on. I am unable to install any add-on; they all do the same thing - sit there forever saying “installing”.

I’m attaching the local log.local-lightning.log (33.5 KB)

Thanks for providing that Local log!

There’s an interesting line in there that makes me think that there’s a bug with one of the libraries that Local relies on. Specifically the issue is trying to rename the add-on “across partitions.”

{"thread":"main","reason":{"errno":-4037,"syscall":"rename","code":"EXDEV","path":"D:\\Users\\Rob\\AppData\\Local\\Temp\\local-4dFLp7pb4\\package","dest":"%%userDataPath%%\\addons\\local-addon-notes"},"p":{},"level":"warn","message":"Unhandled Rejection.","timestamp":"2021-03-19T11:54:48.113Z"}

From the path in that error, it looks like your user profile is installed on the D:\ partition.

I wonder if this is an issue with the Add-on Library code, or more generally installing all add-ons. As a test, can you try manually downloading one of those add-ons and install it using Local’s “Install from Disk” button? To do this:

  1. Navigate to the add-on repository on Github, and view the releases for that addon. For example, here’s the releases for the “Notes” addon:

  2. Download one of the .tgz files

  3. Within Local, navigate to “Addon > Installed” and click the “Install from Disk” link

  4. Use the .tgz file that was downloaded from Github

Can you give that a try and let us know if that workaround allows you to install Local add-ons?

Oh shoot, I see in the original post you mention that you already tried installing from disk.

As a final “ultra manual installation workaround” can you try extracting the add-on to where it would ultimately be on disk?

Here’s what Local’s configuration folder looks like for me on a Mac:

But guessing from the error message in your Local log, you’ll want to put that add-on source code here:


Remember to quit Local and restart it so that it “sees” that addon. You’ll have to navigate to the “Installed” add-ons page in Local in order to actually enable the add-on.

Can you give that a shot and let us know how it goes?

Thanks Ben. I tried the manual install method, by extracting the addon code to the folder where I think it wants it (in this case “C:\Users\Rob\AppData\Roaming\Local\addons\local-addon-xdebug-vscode”) and based on the fact there already was an addon folder in the “C:\Users\Rob\AppData\Roaming\Local\addons” folder. Also tried it on the D drive (had to create an addon folder) and no matter where I put it, Local would not find the addon after restarting it.

I do suspect the problem is the C vs D drive. My C drive is basically my OS only; I install software on D. In this case the Local executable is on D, however it also created a folder on C to store preferences, cache and a heap of other things. I could try uninstalling Local altogether and installing the whole thing on C and see if that works.

I’d be curious to hear if installing Local on the C drive fixes things. I know that Local has had some issues in the past when installed on a different partition in Windows.


I tried uninstalling the Local app and reinstalling on the C drive and it didn’t help. I can tell from the logs it is still trying to do something on the D drive, probably because my user profile is stored on D. So, I don’t see a way I can get this working.

Incidentally, when I uninstall the app, there is quite a bit of data that is left behind. In fact, when I deleted the app and reinstalled it, it still had all the info about the site I had created with it. The second time I uninstalled the app, I deleted all the files/folders that got left behind. Then I reinstalled, and this time it was clearly a fresh install. I’d think that when you uninstall an app, the entire app is removed as if it were never there but it seems that’s not the case with Local.