404 error on site that was working

What issue or error are you experiencing?

I had a site on local that was working fine a couple weeks ago. Since then I added a new site on local as I was working on a new design. I went back to the first site and I’m getting a 404 site not found error. he second site is still working. Not sure why adding a Second Sight cause the first sight to stop working? I’m looking at the local router logs but not sure I understand them. I do see a message at the top of local that says the site’s WordPress URL settings do not match the host set in local. I tried the Fix-It button but nothing changed.

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

I have restarted local. I updated local this morning. I also restarted my machine.

System Details

  • Local Version: 8.1

  • Operating System (OS) and OS version: Windows 11

Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)
error.log (23.3 KB)

Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

wdcga.local is the one not working
wdcga24.local is working

this is the error.log file from Local/wdcga/logs/php
php.error.log (2.2 KB)

Hey @jctech,

It’s hard to say exactly what’s going on. Can provide the Local Logs? You can get a zip of those logs by clicking the “Download Local Log” button from the “Support” tab of Local. See this help doc for more info about that button:

Another thing you might try to get the original site working again is to zip it up and re-import it as a new site. This help doc outlines manually creating a zip of the site:

1 Like

Thanks so much for your replay. I ended up setting up a new site again and importing a backup as I didn’t have any code i was working on. That worked - local certainly makes it easy.


Glad to hear that got things fixed up for you @jctech!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.