A Javascript error occured in the main process

Hey guys, I’m using the latest version of FlyWheel (3.0.4) on Windows, and suddenly I started getting this error, and Local is not starting anymore:


I tried to reinstall Local, but nothing changes. Any ideas of what could be causing this issue?


Just a quick update. I tried uninstalling Local 3.0.4, then installing again. I also tested installing 3.0.3, 3.0.1. And the error keeps popping up. So my guess is that there might be some common component used by Local that is triggering this error.

Then, I tested installing an old version (2.3.3). The error above didn’t popped up. And I saw the UI for a second, then it turned into a blank screen. I also see the upgrade popup:

I’m assuming that there is some sort of component with an old version on 2.3.3, that it’s for some reason not working anymore on my machine. I have no idea what could it be.

The only things I did recently on my Windows 10 computer was:

  • Updated VS code version
  • Installed Windows Subsystem Linux

That’s all I did. So I’m not sure if one of these things could affect Local somehow.

I’m completely lost right now, and can’t work on important projects while Local is broken. ;(

Facing same issue, Have tried updating to current version, samething, Any way in retrieving database files for 3.0.4?