About Database

Issue Summary

When using Local 5.9.4 + 5115 with a Mac OS 10.14.6, do you have to download sequel-pro-1.1.2?

No need to download and use Sequel Pro. Local comes with Adminer which you can use to access the database within a browser.

If you want a more powerful tool for working with the site’s database, you can install SequelPro and use that, or even install and activate the TablePlus add-on for Local to open the site’s database within TablePlus.

Thank you very much Ben Turner for your answer! (Excuse my bad English). I am a beginner and cannot work inside the database. I downloaded without understanding Sequel Pro but I don’t think I managed to install it.
I downloaded Local on my Mac OS 10.12.6 and failed to create the site: “dessinpierrebrody”. I erased it. I updated my Mac to OS 10.14.6. I failed to create the site “sitedepierreBRODY1”. I posted 2 help requests in the “support” category that noone answered. Do I need to activate the TablePlus add-on for this to work?
Is the database in TablePlus in MySQL 5.7.28?
My goal is to improve from scratch my Wordpress site which is hosted in MySQL 5.7.28
Capture d’écran 2020-12-01 à 14.22.40

Hi !

I installed the TablePlus add-on. But my site doesn’t work. I can’t neither open TablePlus nor Adminer.

You must start the site before you can access the database.

Thank you Afragen for your answer! Now I know how to access the database.
The problem is that I can’t neither start the site nor open it or see the admin. It is always writen to change the site domain. I don’t understand why it is not possible to have
Name of the site : le site de Pierre BRODY1
Site Domain : lesitedepierrebrody.local
What did I do wrong ?
Thank you very much for your attention,

Pierre

If all you are wanting to do is to create a Local site and interact with it, you don’t need any of the other database tools. Those are mostly just to help you if you are wanting to do more advanced work with the Local site’s database.

From the screenshots it looks like you are getting closer to having the site be created successfully!

One thing that might be going on is that the site wasn’t able to be created on the old version of MacOS, so retrying that process on the new version of the OS might be helpful.

To do this, try deleting that site by right-clicking on it and selecting “Delete” and then create a new, site within Local.

Hopefully that gets you a site that you can access within a browser, but if you do run into issues, can you please provide your Local Log? See this Community Forum post for instructions on how to do so:

Hi Ben Turner,

Thank you for your answer. I deleted the site and created a new one :“futur site”. But I couldn’t open it in my browser Firefox 83.0
Here is the picture of the Local window and my Local Log
Thank you for your attention and I hope you a nice day,
Pierre

local-lightning .log (22.5 KB)

Thanks for providing that Local Log – it really helps in being able to zero in on the things that Local is encountering!

I’m seeing a few lines that look something like this:

{"thread":"main","class":"Process","process":"nginx","level":"warn","message":"nginx: [alert] could not open error log file: open() \"%%router.runPath%%/nginx/logs/error.log\" failed (13: Permission denied)","timestamp":"2020-12-08T08:08:12.128Z"}

Note this part:

could not open error log file: open() \"%%router.runPath%%/nginx/logs/error.log\" failed (13: Permission denied

It looks like Local is having issues with permissions for the router that it’s trying to create.

Do you have any antivirus software that is installed and might be preventing Local from doing things? If you do, can you try turning it off and then re-starting Local and creating a new site?

One other thing to try – can you run these commands in a terminal? They will examine the folder that the above errors mention as well as try to delete it so that Local can try to create it again from scratch.

  1. Quit Local if it’s running

  2. Open a terminal

  3. Issue this command to examine the folder:

    ls -alh ~/Library/Application\ Support/Local/run/router/nginx{,/logs}
    
  4. Issue this command to delete that router folder (no site data is stored in this folder)

    rm -r ~/Library/Application\ Support/Local/run/router/
    
  5. Open Local and try to create a new site.

Can you give that a shot and let me know how it goes? If you run into more issues, can you paste the text that was printed to the terminal as well as an updated version of the Local log?

Hi Ben.turner!

I opened Terminal (for the first time of my life)

  • I issued the command to read the folder : I send you the copy

  • I issued the command to delete the router folder. I send you the copy

(I don’t know if the command worked, if the folder was found and deleted)

I opened Local.
I deleted the last site : “futur site” and I created a new one : “site de dessins”. But unfortunately It didn’t open. I send you the image of the window.

I thank you in advance for your help in making Local work for my Wordpress site,
Regards,
Pierre



Gotcha – thanks for sharing those screenshots of the terminal. It looks like somehow, a few of those folders are owned by root when they should be owned by your username. As an example, here’s what it looks like when I run that command (note that I have benjamin as opposed to root)

image

From the looks of things, you might need to run that second command with elevated privileges in order to actually remove the folder. Can you try these similar (but slightly different steps)

  1. Quit Local

  2. Issue this command to give us a look at the folders (just as a sanity check)

    ls -alh ~/Library/Application\ Support/Local/run/router/nginx{,/logs}
    
  3. Remove the router folder using sudo because there are folders within router that are owned by root

    sudo rm -r ~/Library/Application\ Support/Local/run/router/
    

    Note: The terminal will ask you for the password you use to login to your computer, but if you start typing, nothing will show up. That’s ok, it’s a “feature” of the terminal so that someone can’t look over your shoulder and see the password you are typing.

  4. Start Local again and try to create a new site

Let me know how that goes, and if you run into issues, can you provide a screenshot of what you found?

Hi Ben.turner! It seems you did it! You are a chief! :innocent:

I did what you wrote. I send you :

  1. the command to give a look at the folders(before remove the router folder)
  2. the command to remove the router folder
  3. and I tried a command to give a look at the folders (after remove)

I opened Local. I deleted the last site. I created a new one : “futurs dessins”
I opened the site and IT WORKED!
Here is the image of the site in Firefox. I haven’t changed anything yet, apart from the name of the site: “future drawings”
Thank you so much.
I will sleep well thanks to you.
I wish you a happy end of the year,
Regards,
Pierre




1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.