After installing the LOCAL package, I proceeded to create the first website, but before creation I get this message, after which the creation procedure is cancelled

Uh-oh! Unable to provision site.

Error: Error: Command failed:
C\Users\Mariano\AppData\Roaming \Local\lightning-services\mysql-8.0.16+6 …\mysqld.exe -defaults-fi…:/Users/Mariano/AppData/Roaming/Local/run/mjPg7U_do/conf/mysql/my.cnf – initialize-insecure
2024-02-12T11:21:48.789269Z 0 [System] [MY-013169] (Server]
C\Users\Mariano\AppData\Roaming\LocaN\lightning-services\mysql-8.0.16+6.…\mysqld.exe (mysqld 8.0.16) initializing of server in progress as process 14304
2024-02-12T11:21:48.793834Z 0 [Warning] [MY-013243] [Server] -character-set-server. The character set UTF8MB3 is deprecated and will be removed in a future release. Please consider using UTF8MB4 instead.
2024-02-12T11:21:48.817519Z 1 [ERROR] [MY-012576] [InnoDB] Unable to create temporary file; errno: 2
2024-02-12T1 1:21:48.81 7580Z 1 [ERROR] [MY-012929] [InnoDB] InnoDB Database creation was aborted with error Generic error. You may need to delete the ibdata1 file before trying to start
UP again.
2024-02-12T11:21:48.817833Z 0 [ERROR] [MY-010020] [Server] Data Dictionary initialization
2024-02- 12T11:21:48.817841Z 0 [ERROR] [MY-013236] [Server] Newly created data directory
C:\Users\Mariano\AppData\Roaming\Local\run\mjPg7U_do\mysql\data\ is unusable. You
can safely remove it.
2024-02-12T11:21:48.818365Z 0 [ERROR] [MY-010119] [Server] Aborting
2024-02-12T11:21:48.819342Z 0 [System] [MY-010910] [Server]
Shutdown complete (mysqld 8.0.16) MySQL Community Server - GPL.
at ChildProcess.exithandler (nodechild_process:430:12)
at ChildProcess.emit (node:events:513:28) —
at maybeClose (node:internal/child_process:1091:16)
at ChildProcess._handle.onex it (node:intemal/child_proce$s:302:5)

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc


System Details

  • Local Version:

Version 8.2.1+6583

  • Operating System (OS) and OS version:

Edizione Windows 10 Home
Versione 21H2
Data installazione: ‎15/‎03/‎2021
Build sistema operativo 19044.3086
Esperienza Windows Feature Experience Pack 1000.19041.1000.0

Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)

I do not have a log because LOCAL does not allow me to create the site

Hello, welcome and thank you for the question! :wave:

Do you have anti-virus software installed on your computer that may be causing issues?

Here is some information and troubleshooting steps you can try related to anti-virus + Windows:

Let’s start there!


Estou com esse mesmo erro e ainda nao consegui resolver, uso win10. ja bati muita cabeça. se alguem poder dar uma luz. agradeço :frowning:

Thank you for the response. I checked that my C:\Windows\System32\drivers\etc was already set to full control, however, the issue persisted until today. Interestingly, I tried running ‘local’ as an administrator and magically everything started working correctly. I am grateful for the help and information provided, which allowed me to resolve this issue. The collaboration and support from everyone have been invaluable. Thanks again.

1 Like

Have you tried checking your host file permissions or for any other security blockers?

ja tentei amigo. aparece essa mensagem no canto da tela ‘‘local está solicitando privilégios administrativos para modificar seu /etc/host/file.’’
mas n sei indentificar o problema

You should be getting prompts like this:

If you’re not seeing both, then you might not have admin privileges to be able to proceed. If you’re certain that you are an admin with full control and the hosts file isn’t set to read only you can check some other things:

Are you running other developer applications simultaneously? That could also cause similar issues. Apps like MAMP, XAMPP, or Docker for example.

Do you have any antivirus, security, or firewall applications that could be blocking Local?

aparece essas mesmas coisas das imagens que vocÊ mandou, eu so tenho o windows defender e sou o usuario admin… até formatei o meu pc e instalei win11 mas mesmo assim contiunuou o mesmo erro. acredito que seja na minha internet o problema…

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

Have you been able to test on another network to rule that out?