What issue or error are you experiencing?

I have installed the Better Docs plugin via Essential Addons on a local test site. The setup of settings confirms it has finished “successfully” and then pops up a message to say “you don’t have permission to access this page”
The plugin does not therefore fully complete setup and there is nothing else to see.

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

Uninstalling and redoing has same result.
I have had no issue installing BetterDocs on a live hosted site with all the same plugins so it seems an issue with Flywheel local only.

System Details

  • Local Version:
    7.1.2 + 6410
  • Operating System (OS) and OS version:
    Mac Ventura 13.5.1 on M1 Apple Studio

Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)
error.log (2.4 MB)
php-fpm.log (14.5 KB)

Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

A sort of workaround!
BetterDocs installs with no issues on my BlueHost site. So using wpVivid backup plugin made backup of live site which is under maintenance and then downloaded and restored to local site.
Even better installed mainWp remote site manager which works brilliantly and has a wpVivid extension which makes the whole thing much easier.
Still no idea why BetterDocs gives permission errors when install attemptws on a Flywheel local site.

Hi @johnbirt! Glad you were able to find a workaround! The error it’s throwing is kind of generic so it’s hard to tell exactly what might be the case. I tried searching through their forums but I couldn’t find any history of someone running into issues getting it to work locally or getting the same error. This might be a good question to chase down with the plugin developers to see if there are any known issues to roadblocks to get this work locally. Maybe there is something unique with the licensing or the types of calls it needs to make. We’ve seen similar issues with other Elementor plugins or features.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.