Boot2Docker.iso hash does not match! Waiting for an IP… Too many retries

local-by-flywheel.log (9.0 KB)
On the Mac. Local doesn’t start. The log says both “Boot2Docker.iso hash does not match!” and “Check network to re-create if needed… Waiting for an IP… Too many retries waiting for SSH to be available. Last error: Maximum number of retries (60) exceeded”

I also tried starting after turning off my VPN, firewall and real-time virus scanning. No luck.
Log attached. What to do? Thanks.

Problem solved. Although I had tried previously to do a complete removal and re-installation of Local, I just found something else to delete as well, the “~/.docker/machine/machines/local-by-flywheel” folder. Once I delete that, delete the app. and associated files and re-installed, everything worked!

Now if I can just figure out to import my sites from my old Mac…

Hi @burgermark,

Glad you got it sorted! Did you use the Migration Assistant when moving to your new Mac?

If you have access to the site folders, try zipping up the folders and then dragging and dropping them onto Local’s Dock icon or main window to initiate an import. :slight_smile:

Wow, I didn’t know importing the migrated sites was so easy. Just drag-and-drop. Dynamite! Thanks Clay, you made my day.

I did the Mac-to-Mac migration using Migration Assistant but still had problems because:

  1. My new Mac (macOS 10.13.4) refused to let VirtualBox run, until I got it allowed. (There appears to be a bug whereby the “Allow” button in System Preferences / Security & Privacy may not appear and if it does appears it may or may not (mostly not) do anything when clicked. I’ve reported this to Apple.)
  2. Docker refused to run, until I thoroughly removed all of it’s associated files, preferences and what-not, and then re-installed.
  3. I seem to have screwed-up Local-by-Flywheel trying to import my sites in a kludgy way. Only cured by a thorough removal of all associated files beyond the app itself and then re-installation. Both de-installations done using an app that finds and deletes associated files.


Glad you got it sorted! Thanks for the details!

I’ve heard other reports of the Mac migration not handling VirtualBox and Docker particularly well. I’ll make a note to see if there’s anything we can do to make the migration easier. :slight_smile: