Can not pull/push from WP Engine

Bug Summary

No changes done, suddenly when pull/push from WP Engine the list of files always show 0.

Steps to reproduce

I tried couple of fixes when push/pull not working for the existing site, but none of following worked.

  • Update to latest version of 6.6.0+6231
  • Create new site in Local, connect to WPE. Site/environment dropdown shown up for both pull and push, but file list show everything as 0 (empty list)
  • Get a backup zip from production site, import to Local. Connect to WPE. Pull not possible, site dropdown shows “Already connected to Local”, environment dropdown not shown. Push file list shows everything as 0. I then make a small change in wp-content to test. Push file list still shows everything as 0.

Please advice.

Environment Info

Describe your environment.

  • What Operating System are you using?
    MacOS Monterey
  • What versions of site software (Nginx, Apache, PHP, MySQL) is used?
    PHP 8.1.9, mySQL 8.0.16
  • What version of Local is installed?

Supporting info

Please provide your Local Log. See this Community Forum post for instructions on how to do so:

Include any screenshots or video recordings of the issue to help others reproduce.

Hi @anh Could you start here? Troubleshooting Connect to WP Engine - Local

If you’re still having trouble after that could you share your Local Log? There are some different ways to access and share Local Logs. For us to be able to troubleshoot thoroughly, please click the Download Local Logs button from the Support tab in Local. This will generate a zip archive that contains the Local log along with some other diagnostic information to help quickly zero in on any issues that Local is encountering.