Local Community

Can´t restore backup from GoogleDrive on Windows (404 Not Found nginx/1.16.0)

Hi everyone,

I have backed up a WPBackup to google drive with local. But when I want to restore the backup with local, it doesn’t work. There are 2 flashing dots at “Wordpress Version” and when start the site it only opens a page which says: 404 Not Found
nginx/1.16.0. I use Windows 10 and it happens on my laptop and Desktop.

Otherwise Local works fine. I can create new Sites, edit and backup them.
Any Ideas?

Hey @WpNoob – Welcome to the Local Community Forums!

When you say you created a WPBackup, did you do it by using the Cloud Backups addon, or was this a different way of making a backup?

That 404 error sounds odd – can you take a screenshot of what you’re seeing so that I have a better idea of where the issue is occuring?

To get even more info about what’s going wrong, can provide the Local Logs? You can get a zip of those logs by clicking the “Download Local Log” button from the “Support” tab of Local. See this help doc for more info about that button:

Hi Ben,

i created the backup with the cloud backup addon.
I tried it on 2 different computers.


local-logs.zip (5.4 KB)

I like the tool so any help would be appreciated.

Like you WpNoob, I like Local too but I have this issue and its been over a month now with no remedy.

:frowning_face:

No Idea @ localwp? @ben.turner

I’m having the same issue as WpNoob.

Created an original site on desktop. Used cloud backups plugin to save a copy to Google drive. On my laptop I tried creating a site from cloud backups add-on, using the copy from Google drive. It creates the new site on the laptop, but when you launch the WPadmin panel it gives a 404 error.

Maybe someone from support would like to answer the question, if this occurs with several people?

Hello,

I am unable to reproduce this issue on MacOS, so I have confirmed the issue is specific to Windows. I found an interesting line in the error log -

{"thread":"renderer","stack":"TypeError: Cannot read property 'name' of null\n    at setSelectedSite (%%userDataPath%%\\addons\\@getflywheel-local-addon-backups\\lib\\renderer.js:35094:51)\n    at %%userDataPath%%\\addons\\@getflywheel-local-addon-backups\\lib\\renderer.js:10863:20\n    at e.i.produce (%%userDataPath%%\\addons\\@getflywheel-local-addon-backups\\lib\\renderer.js:25612:15841)\n    at %%userDataPath%%\\addons\\@getflywheel-local-addon-backups\\lib\\renderer.js:10862:64\n    at Array.reduce (<anonymous>)\n    at %%userDataPath%%\\addons\\@getflywheel-local-addon-backups\\lib\\renderer.js:10829:25\n    at combination (%%userDataPath%%\\addons\\@getflywheel-local-addon-backups\\lib\\renderer.js:30620:29)\n    at dispatch (%%userDataPath%%\\addons\\@getflywheel-local-addon-backups\\lib\\renderer.js:30374:22)\n    at %%userDataPath%%\\addons\\@getflywheel-local-addon-backups\\lib\\renderer.js:10539:22\n    at %%userDataPath%%\\addons\\@getflywheel-local-addon-backups\\lib\\renderer.js:30132:16\n    at Object.dispatch (%%userDataPath%%\\addons\\@getflywheel-local-addon-backups\\lib\\renderer.js:10393:32)\n    at onGoBack (%%userDataPath%%\\addons\\@getflywheel-local-addon-backups\\lib\\renderer.js:33417:23)\n    at Object.ba (%%appPath%%\\node_modules\\react-dom\\cjs\\react-dom.production.min.js:14:84)\n    at ja (%%appPath%%\\node_modules\\react-dom\\cjs\\react-dom.production.min.js:14:238)\n    at ka (%%appPath%%\\node_modules\\react-dom\\cjs\\react-dom.production.min.js:14:292)\n    at oa (%%appPath%%\\node_modules\\react-dom\\cjs\\react-dom.production.min.js:15:72)\n    at lc (%%appPath%%\\node_modules\\react-dom\\cjs\\react-dom.production.min.js:52:170)\n    at jc (%%appPath%%\\node_modules\\react-dom\\cjs\\react-dom.production.min.js:51:255)\n    at mc (%%appPath%%\\node_modules\\react-dom\\cjs\\react-dom.production.min.js:52:334)\n    at sc (%%appPath%%\\node_modules\\react-dom\\cjs\\react-dom.production.min.js:56:10)\n    at Ia (%%appPath%%\\node_modules\\react-dom\\cjs\\react-dom.production.min.js:287:189)\n    at Ma (%%appPath%%\\node_modules\\react-dom\\cjs\\react-dom.production.min.js:19:57)\n    at Rc (%%appPath%%\\node_modules\\react-dom\\cjs\\react-dom.production.min.js:70:279)\n    at id (%%appPath%%\\node_modules\\react-dom\\cjs\\react-dom.production.min.js:69:102)\n    at exports.unstable_runWithPriority (%%appPath%%\\node_modules\\react-dom\\node_modules\\scheduler\\cjs\\scheduler.production.min.js:19:467)\n    at cg (%%appPath%%\\node_modules\\react-dom\\cjs\\react-dom.production.min.js:122:325)\n    at Ga (%%appPath%%\\node_modules\\react-dom\\cjs\\react-dom.production.min.js:287:48)\n    at gd (%%appPath%%\\node_modules\\react-dom\\cjs\\react-dom.production.min.js:68:371)\n    at HTMLDocument.sentryWrapped (%%appPath%%\\node_modules\\@sentry\\browser\\dist\\helpers.js:75:23)","eventId":"0ec11f672c5042f2bbcc26ceb78b38da","level":"error","message":"Cannot read property 'name' of null","timestamp":"2022-02-11T15:54:20.000Z"}

{"thread":"main","class":"BackupAddonRestoreService","errno":-4048,"code":"EPERM","syscall":"lstat","path":"C:\\Users\\Andy\\Local Sites\\mysoulblossomsbackup\\logs\\nginx\\error.log","level":"error","stack":"Error: EPERM: operation not permitted, lstat 'C:\\Users\\Andy\\Local Sites\\mysoulblossomsbackup\\logs\\nginx\\error.log'","message":"EPERM: operation not permitted, lstat 'C:\\Users\\Andy\\Local Sites\\mysoulblossomsbackup\\logs\\nginx\\error.log'","timestamp":"2022-02-03T11:58:22.614Z"}

I will make a ticket for the development team to look into.

Thanks,
Austin

Hi, I also have the same Issues and I noticed that there is no data in the app folder except an sql-folder. Makes sense that there is a 404 then. Hope you can fix it soon!

Same Issue on Windows 11. The Issue is that the backup isn’t even downloaded inside the app directory

In exactly in the same boat as Nikolai, Gryphon, WpNoob etc.

  • The Backup is successfully created and stored in Google Drive from Machine 1
  • The Backup is visible on Machine 2 and option to create from Backup appears to work
  • During “Restoring Backup” phase - just stops, no error, appears to have worked, but DB missing, Site files are missing

For some reason the restoration just doesn’t happen, no files appear to be downloaded from the cloud storage.

Would appreciate a solution if available
local-logs.zip (5.1 KB)