Local Community

Can't establish a secure connection

Issue Summary

One or two sentence summary of the issue.
Im able to get into the wordpress dashboard but cant access any pages or the front end of the site. error please see screenshot.
the site host is set. How can I fix this issue?

“Safari cant establish a secure connection to localhost”

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?
    Yes

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?
    Yes

Replication

Describe the steps that others can take to replicate this issue. If you have screenshots that can help clarify what is happening, please include them!

Ive tried changing URL settings>General WordPress Address (URL) Site Address (URL)

System Details

I notice a couple of things that might be going on:

  1. There’s a slightly newer version of Local that’s been released. Can you try installing that and see if that allows you to create sites? https://localwp.com/releases/

  2. I also see that the OS that’s running is Big Sur. Other users have mentioned issues with trusting the SSL certificate (which appears to be what’s going on here)

    Can you try the solution found in this topic and let me know if it gets things working?

Let us know if either of those things get you what you need or if you run into anything else that isn’t working for you!

Hi,
The problem is still there with the latest Local 5.9.4, Big Sur and M1 Macbook pro. Also, quite often I have to go to the Preferences >> Advanced and switch router mode to localhost. Otherwise no sites will open.

1 Like

Thanks this worked switching Local to Site Domains fixed it

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.