Can't get Local to work after numerous attempts to install, including VirtualBox upgrade

Hi there,
I have tried multiple times to install Local and consistently receive this error:

Error setting up host only network on machine start: The host-only adapter we just created is not visible. This is a well known VirtualBox bug. You might want to uninstall it and reinstall at least version 5.0.12 that is supposed to fix this issue.

I have done this several times. I am still unable to use Local. I’ve heard it’s great from my MAC friends. I am on a Windows 10 machine and currently use ServerPress’ Desktop Server.

Hi Cindy,

I apologize for the poor installation experience!

Can you try the following:

  1. Download and install the most recent version of VirtualBox for Windows:
  2. Restart your PC
  3. Re-open Local

Hi Clay,
Thanks for your reply. I already did have VirtualBox version 5.2.20. I did as you suggested and downloaded from the link you provided and restarted my PC. When I tried to open Local, it just hung on “Starting Local Machine …” for about 15 minutes, then on to “Checking System” for another 10+ minutes. It will not continue past that point.

What can I do?
Thank you,

Great, it seems like we’re making progress at least :slight_smile:

Can you please provide your local-by-flywheel.log file? See How do I retrieve Local's log file? for instructions on how to do so.

That should give us more information on why it’s stuck on “Checking System”

local-by-flywheel.log (60.2 KB)

Hi Clay,
I posted my log but have not heard back from you. I am still unable to use Local by Flywheel - would appreciate any assistance.
Thank you,

Hi Cindy,

Sorry for the delay! It looks like there were some issues when Local’s virtual machine was created.

Please try the following:

  1. Quit Local by Flywheel
  2. Open VirtualBox
  3. Disclaimer: this step is potentially destructive and will remove your site databases if you have existing sites in Local that are not backed up. … Remove the local-by-flyweel VM by right-clicking on it and going to Remove and then Delete all Files
  4. Re-open Local and proceed with the installation. Be sure to click Yes/Okay on any prompts from Local or VirtualBox.

Hi Clay,
I performed the steps as you described. VirtualBox and Local by Flywheel both updated. Now I am trying again, and it got an error. Here is a screenshot of the error:

Thanks for your help in advance!

A mi me pasa lo mismo, haber si hay solución …