Can't get Local to run on Windows 10

Local keeps getting hung up, either when trying to start the local machine or just when it is first opening. I have attached my log file. Help! local-by-flywheel.log (60.6 KB)

Hey Bowler,

Looking into the log, the process of starting the VM hangs in the same error, which is specific to the code trying to start it. Even having no knowledge of Local’s code I have some ideas for you that won’t be harmful.

For starters: Do you have any work in Local? If you have any work in this installation of Local, be aware that you database is backed up in the site’s local folder, but it might not as well due to an error, so your database will be in the Virtual Machine. Which means that messing with VirtualBox or uninstalling it means youl’ll lose this work.

Ok, so first thing I would do is to open VirtualBox beside Local when starting it, so you can see the Virtual Machine starting and if it starts normally. If not, you can start the machine manually and see if it works that way. Something can be preventing Local’s communication with VirtualBox.

Also, if you don’t have any work in there, you can try uninstalling everything (Local by Flywheel and VirtualBox) using this walkthrough: How do I uninstall Local on Windows? and make a new fresh install. For a number of times this helped me with problems.

If you have any new information, I’ll be here! Reply away so we can help you further :smiley:

I have no current work in Local. I was trying to install it instead of using my demo website for clients. I will try that and see what happens. I had it almost open one time then it crashed and wouldn’t ever open again.

Ok. So I got it to start and then started making a new site and it quit on me. Here is the updated log file.local-by-flywheel.log (72.5 KB) I am going to try a fresh install again.

This is what happens after the fresh install. local-by-flywheel.log (21.0 KB)
:woman_facepalming: I just want to work. :joy:

Yeah, it gives the same error message as before…
Since apparently it’s related to Local by Flywheel code, I don’t really know how to solve it, maybe @ben.turner can help! :smiley:

1 Like

Hey @mbmarketing4you –

It almost seems like each new install is using old values for when it is created. Do you have the Docker Toolbox installed for doing other dev work with Docker?

If you don’t know what that is, and all you have installed is Local, can you try uninstalling again using the link that @atempel shared: How do I uninstall Local on Windows?

After doing that, delete the .docker directory in your home folder. It will be a hidden directory. That’s the only other place I can think of that would have any settings related to the errors in the Local log.

Once those have been removed, restart Windows and try re-installing Local.

Let me know how that goes!

– Ben


I have not installed docker to do any other dev work that I know of. Ill try that and let you know what happens.

It’s running now. Thanks for the help!

1 Like

Hello everyone. I was having the same problem. Followed every instruction in Ben’s post to the letter and it solved my issue.

This topic was automatically closed 12 hours after the last reply. New replies are no longer allowed.