Can't load Flywheel local sites after upgrade to Sierra

I upgraded to Sierra. It broke my dev environment. Quelle surprise! (Not).

I’ve got everything working again now except that Flywheel Local sites will no longer load. I’m using dnsmasq, which I was also using before when LBF was working just fine.

The site was added to my /etc/hosts file by the app like so: #Local Site

Things I’ve tried:

Adding ‘nameserver’ to /etc/resolver/dev file that gets read by the dnsmasq config file.

Deleting and re-importing a local site from a backup and assigning a .local domain to it instead of .dev (dnsmasq is only configured to route .dev local domains).

I’m using LBF version 1.4.2
OSX 10.12.3

I have sooo many sites to build and I would really love to get this working again!



Hi Kronda,

So sorry for the trouble!

Can you try completely disabling Dnsmaq for now?

Also, can you try restarting that site in particular in Local? That’ll trigger the router to reinitiate.


I was able to resolve by deleting the site and reinstalling with only the default settings. Turns out I can’t have Flywheel Local sites in my Sites folder because of my httpd-vhost.conf settings.

I let it create a ~/Local Sites folder instead and everything is working.

Thanks for the reply!


1 Like

Same problem here. I’ve tried every tip i could find on this forum and none of my sites are working. Could this be a macOS Sierra issue? Really need help resolving this as none of my local sites are working.

1 Like

same problem

Hi @seothemes,

Very sorry for the trouble!

Are you running anything such as Valet, Gas Mask, or dnsmasq?

Hi Clay

No, not running any of those.

I’ve kind of given up now, just can’t get it working.

If you’d like we can set up a time to troubleshoot this over a screen sharing service. Just let me know if you’re interested.

1 Like

That would be great. I’ll send you an email :slight_smile: