Can't run MAMP and Local -- PLEASE HELP!


I installed Local on a Macbook (10.14.6) that already had MAMP running on the localhost. I have projects in both I need to access. However, now Local works and MAMP sites will not connect (" localhost refused to connect.").

How do I fix this?

I’m thinking I can export my projects on Local and reinstall Local to not use localhost… just not sure how to reinstall local to not use localhost. Is there an option upon installation? Plus, will that fix MAMP? Do I need to erase the incidents of Local from my hosts file?

Thanks in advance!

Hi @typosruinokes,

Sorry for the confusion! The download form at currently serves Local Lightning as the default download. Local Lightning does currently conflict with MAMP and the one not in use will need to be stopped prior to using the other. We have plans to enable the two to work simultaneously in the coming months. :slight_smile:

If you need to run Local by Flywheel with MAMP simultaneously now, you can use Local by Flywheel 3.3.0 which can be downloaded here: Local by Flywheel 3.3.0

Thanks for the clarification!

However even with Local turned off, I get the same error… is there a setting that is changed when installing Local that would effect MAMP?

The reason I now need to revert back to MAMP os because Local does not seem to work properly with the popular Divi theme…

This is on a different subject – I’m using the Wordpress theme “Divi” by Elegant Themes. In one project I’m attempting to export their “Divi Layout Library” which is stored in the database. This should take a matter of seconds. However, after a few hours, it works its way up to 86% then freezes. I contacted the theme who gave me various instructions, all of which concerned the host. Eventually, they asked me to check the error logs. When I checked Local’s logs, there was nothing.

Any suggestions? I either need to get MAMP working again or have Local work properly. Please help.

Thank you

Is MAMP throwing a specific error, or are you only seeing the error in your browser?

Are you having trouble with Divi and Local by Flywheel or Divi and Local Lightning?

I can reach a list of my local sites at “http://localhost:8888/” but when I click on one, I get

re Divi
Local by Flywheel

So this entire time I’ve been using Local by Flywheel 3.3

Got it!

Are the site domains/hostnames the same in both MAMP and Local by Flywheel? If so, you’ll need to make them different. The easiest route to do this is to most likely open up Local by Flywheel and change the site domain of the sites that share domains with those in MAMP.

@clay They are not the same. They are completely different. The ones at flywheel are site.local and the MAMP is localhost/site

Honestly, I would be thrilled right now if I could just export the layouts on Divi. That’s why I need ot get into MAMP anyway. I need ot transfer a site from Local to MAMP using a plugin so that I can export these layouts. There seems to be an issue with Local’s database. I could strangle it!

Is there a setting in Flywheel that could be changed?
How do I fix MAMP?

In that case, it sounds like it’s an issue with MAMP. Local by Flywheel has no known conflicts with MAMP as long as the site domains are different.

Same! :slight_smile:

If you have time, can you try exporting the layouts again with Local by Flywheel? Once the error occurs, please provide the site log files as well as the Local Router error log.

You can get the site error log files by right-clicking the site in Local’s sidebar, then going to “Reveal in Finder”. Once the folder shows, you should see a logs folder.

To get the Local Router error log, go to Help » Reveal Local Router’s Log in the top macOS menu bar.

I’m having a similar issue with Local Lightning and MAMP. I discovered that they don’t work well together, so I turned off MAMP while trying LL. But now when I try to start the MAMP servers again I get this error:

“Apache couldn’t be started. Please check your MAMP installation and configuration.”

I stopped and quit LL and LbF but still can’t get MAMP Apache server to start. Any idea why?

Hi @andrewmowe,

Try running killall nginx in Terminal and then try starting the servers in MAMP.

1 Like

This worked, thank you. Any way to avoid having to do that in the future?