Can't update Local to 8.3.2 (current version can't be uninstalled)

What issue or error are you experiencing?

When I try to update Local to latest version, after downloading the update and during the installation i get the error that Local can’t be closed…
If I click “Cancel” on the dialog box, the error suggests that the current version couldn’t be uninstalled (screenshots below)


Initial error:
Screenshot 2024-03-15 140257

Error message upon clicking “Cancel”:
Screenshot 2024-03-15 144917


System Details

  • Local Version: Version 8.3.1+6650 - trying to update to 8.3.2

  • **Operating System (OS) and OS version:

Edition Windows 11 Home
Version 23H2
Installed on ‎24/‎10/‎2023
OS build 22631.3296
Experience Windows Feature Experience Pack 1000.22687.1000.0
**

Local Logs

local-logs1.zip (178.9 KB)

Hi @SandiaCreative

Are you running this update under an admin user account?

Is your hosts file set to read only?

Do you have any other security, firewall or antivirus in place that could be blocking the update?

Ok, so I tried turning the AV off and running Local as administrator and it worked. Two things though:

  1. I have tried that exact thing yesterday and it didn’t work, so I don’t know what happened there
  2. I have never had to do this before to update Local, so I’m wondering why did it happen now?

Either way, thanks for your suggestion(s) ,)

Hi @SandiaCreative

Glad to hear it’s working! It’s possible that something on your machine just reset due to the changes in Local or some other type of update on the machine. We aren’t seeing any widespread issues with this but these recommendations are ones that we frequently provide to Windows users as permissions and security can be finicky with updates or new applications.