Changing Local's default Email address

When I first started using Local by Flywheel I never changed the dev-email@flywheel.local admin Email address when creating my first website.

My website has been running for months with no problem on a hosting provider but now I can’t login to the Wordpress dashboard on the hosting service.

My site backup (of course) also has the default dev-email@flywheel.local Email address and when I go into Wordpress settings and change it to my own Email address when I return later to the Wordpress Settings page it tells me the change is pending. Presumably the change notification has been sent to the default dev-email@flywheel.local Email address for verification so I am going round in circles…

I’m running Local on Windows 10.

Any help and advice would be appreciated.

1 Like

@CJRC There are a number of ways to update the WP admin email address for a hosted site without triggering the confirmation request, including:

  1. If you have access to WP-CLI on your hosting service, use wp option update admin_email (obviously replacing with your own email address).
  2. You can use the WP all-options page (at wp-admin/options.php), find the “admin_email” entry, and change the value to your email address. Make sure to scroll to the bottom and click the “save changes” button.
  3. Update it directly in the database. See option 3 here:
    How to Change the WordPress Admin Email (3 Methods)

If you need to update the address in your Local environment, you can use the three options above (except that you’d use Adminer for #3). With your Local environment, you can also access the email sent within Mailhog, and just use the link there to confirm.

Hope this helps!


Thank you for the information. Once I was able to access the CLI I was able to change the Email address and it shows in Wordpress Settings. According to Wordpress Settings I am supposed to receive a confirmation Email to confirm the change hast been successful. That hasn’t happened so far so I will have to wait and see what happens next !

I don’t know whether the highlighted text in your option 3 is supposed to be a link to something but if so it doesn’t work !

1 Like

Hi there @CJRC -

I’m glad @burt was able to help with changing your email address (thank you, Burt!).

Regarding the confirmation email - I have a few follow up questions.

  1. Are you attempting to send this confirmation email from your Local site? If so, you won’t actually receive the email but you can find it in Mailhog (which can be accessed from your Local site screen under Tools).

  2. If not, if your site is already live with your host + you’re not receiving the email, you’ll want to reach out to them regarding email sending issues. Sometimes hosts can support you with SFTP issues related to email or give you the next steps.

Let me know if this helps,



I am looking at Settings → General on the Wordpress dashboard for the website.

Next to Administration Email Address my updated Email address is shown in a box and underneath the box it say -

This address is used for admin purposes. If you change this, an email will be sent to your new address to confirm it. The new address will not become active until confirmed.

I am not trying to send a confirmation Email it is Wordpress saying it will do so and from what the message says (as I see it ) you have to confirm receipt of the confirmation Email (to your new address) before it is accepted as the new Administration Email Address . That is how I see it.

I put my personal Email address in as the new address and I expected to receive a confirmation request to it to confirm it is the new admin address but that hasn’t happened.

I hope this makes sense !

The address has been changed successfully. You won’t receive an email now unless you change it again through the WP admin. Changing it with the CLI will not generate a confirmation request email.

If you’re not seeing the message that says, “There is a pending change of the admin email to…” (as shown below), then you’re all good.


1 Like

Thanks, I’ll keep my fingers crossed that is the case ! :grinning:


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.