Local Community

Chrome not opening Adminer when using port 10080

Issue Summary

I click on Open Adminer link within Local Pro and get:
The webpage at http://localhost:10080/?username=root&db=local might be temporarily down or it may have moved permanently to a new web address.

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?
    All

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?
    Yes, everything on the front end works.

Replication

Describe the steps that others can take to replicate this issue. If you have screenshots that can help clarify what is happening, please include them!
Just click on Database → Open Adminer

System Details

  • Which version of Local is being used?
    5.10.5 + 5403

  • What Operating System (OS) and OS version is being used?
    macOS Big Sur 11.4

local-lightning.log (319.6 KB)

1 Like

i have the exact same issue. downloaded version local 6.0 and issue persists.

3 Likes

Yup, it is happening to me also.
At first, it was a virtual host issue, then conflict with localhost, then SSL trust issue & now it is Database issue.

CHROME
I click on Open Adminer, issue
http://localhost:10080/?username=root&db=local -

This site can’t be reached

The webpage at http://localhost:10080/?username=root&db=local might be temporarily down or it may have moved permanently to a new web address.

ERR_UNSAFE_PORT

FIREFOX

This address is restricted
This address uses a network port which is normally used for purposes other than Web browsing. Firefox has canceled the request for your protection.

Somehow SAFARI - the database URL opens fine. :slight_smile:

Also, I think, imo, renaming from flywheel to localwp was not a good idea. Its is preventing from right answers in search results.
local & wp both are very common word and searching with local text is very large and vague.

I was about to explode here but just in time, i chose SAFARI to check the URL and luckily the database opened. That is the truth.

Ooof

1 Like

Seeing the same issue - according to the Reddit thread below, Chrome 91 is blocking traffic to port 10080 “because it is used for the NAT Slipstream 2.0 vulnerability” - so looks like Safari is the only option until that changes, or we have the ability to change the port in Local

1 Like

Hi!

In my case was on Debian 9, and to solve this adminer problem that I have had in some local sites:
http://localhost:10091/?username=root&db=local

This site can’t be reached

localhost refused to connect.

and not on another:
http://localhost:10090/?username=root&db=local
Here es ok

I solved it by installing “WP phpMyAdmin” plugin

I’m having a lot of other issues, tried several from here and cannot found any solution.
I cannot use domain, directory multisite, …

Best regards
Moz

A post was merged into an existing topic: ERR_CONNECTION_REFUSED while opening Adminer on Linux (Pop OS)

We have some work scheduled for Local to not use that port for these various services.

There’s still likely some sort of issue that a number of users are encountering.

Hi!

Chrome
Version 90.0.4430.212 (Official Build) (64-bit)

and FireFox

The same problem

Thanks for your response!

The Adminer does not work with php7.4x

Just following up with this topic – I’ve moved it to our “Bugs” category along with renaming it to be explicitly about adminer issues when run on port 10080.

I’ve also added some additional details to our internal bug report. I don’t have an ETA for when this will be worked on, but everything is set! If this is something that’s important to you, please up-vote it so that we can help prioritize it!

We’re facing this same issue on Ubuntu on both Chrome and Firefox. We’ve tested this on both v6 and v6.1. Our port number 10010. The issue actually happens on all sites and they have different ports for Adminer - 10015, 10016 and so on.

This is impacting our workflow a lot so it would be really helpful if this can be solved soon. Or if there’s a temporary workaround to access database, do share that. We tried TablePlus extension but the button for that shows disabled. Thanks.

Hey @ram – This current topic is specifically related to issues with Adminer running on port 10080 and being accessed via Chrome.

What you’re describing sounds a bit more like this related Adminer bug under *nix systems:

Can you take a look at that related topic and upvote it? I think the reason that TablePlus isn’t working is that it currently only supports MacOS.

Thanks @ben.turner for pointing me to the right direction. Good to know that I’m not the only one with this issue and you’re aware of this issue and looking into a solution for this.

1 Like

Same issue here :frowning:

I used to be able to access Adminer with Safari, but now it seems even Safari won’t open these links. I have Safari version 15.0 (16612.1.29.41.4, 16612). I get no error, just a blank page with “about:blank” remaining in the header. If this is common, this would increase the priority of fixing this, as I had no problems using Safari to access Adminer, but now it seems I just can’t access the database at all.

2 Likes

Hi @msaari,

Seems like Safari has also started blocking the 10080 port, just like Chrome and Firefox.

I’ve just starting experiencing this. I’ve been using Safari, so only just noticed it when updating to Monterey.

Was there ever a fix or work-around?

Alright, I was just facing the same issue…

And here is my 2 cent work around solution:

  1. Delete the site which have this weird issue, backup everything in case you have good work there to keep going on.
  2. Create one meaningless site, I named it “F**K10080”, you know what I mean.
  3. Create another site, which you will continue the good work.

Done, problem solved!

Updated: Oh, forgot to mention that, I wasn’t having issue with Adminer with WordPress setup in LocalWP, but the MailHog. Well, I guess it is the same thing.

Happy coding! :v:
Liang

That’s right. I changed PHP version to 7.3.5 and run fine.

Thanks

PHP version is irrelevant here, this is another issue.

Still not working with version 6.1.8.