Local Community

ERR_CONNECTION_REFUSED while opening Adminer on Linux

Hello all,

i can’t access Adminer at http://localhost:10005. There is error displayed like in a title. I try this on Pop OS (Ubuntu 20.04 based distro). Is there anything blocking this port? How to find out what the problem is?

PS: Sites work just fine with domain names (for example: domain.local) and with SSL, and also Mailhog works at http://localhost:10000 without an issue.

Best regards.

2 Likes

I’m also having this issue. Ubuntu 20.04
Interestingly, it seems to work with PHP 7.3, but if I use PHP 7.4, that’s when I get the issue.

1 Like

Same error here (linux mint 20.1)
It works with php 7.3 but doesn’t work with php 7.4 or 8

1 Like

seems the problem is not resolved yet. Adminer seems to be working fine on PHP7.3 but not working on PHP7.4 on linux systems i tried it on latest popOS and mintOS.

1 Like

Yeah, that’s the thing. It only works with PHP 7.3. With other versions it throws an error.

1 Like

Thanks everyone for being persistent and working with me to reproduce this. I’ve finally been able to replicate on my Ubuntu machine. It looks like, for some reason, Local thinks that an existing FPM instance was already on the socket:

I’ve created a bug report for the team to take a closer look and see what can be done!

I’ve also moved this forum topic under the “Bugs” category so that it can be voted on, so to help me show how important this feature is to you, be sure to up-vote!

2 Likes

I have a similar issue. When I click the “Open Adminer” I see:
http://localhost:10005/?username=root&db=local
with

This site can’t be reached

localhost refused to connect.
ERR_CONNECTION_REFUSED

Chrome
Linux 5.8.0-55-generic #62~20.04.1-Ubuntu SMP Wed Jun 2 08:55:04 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux
Local 6.0.0+5444

1 Like

Hey @kostiantyn.petlia – I’ve moved your reply to this bug report so that you can be updated as things are worked on!

We’re facing this same issue on Ubuntu on both Chrome and Firefox. We’ve tested this on both v6 and v6.1. Our port number 10010. The issue actually happens on all sites and they have different ports for Adminer - 10015, 10016 and so on.

This is impacting our workflow a lot so it would be really helpful if this can be solved soon. Or if there’s a temporary workaround to access database, do share that. We tried TablePlus extension but the button for that shows disabled. Thanks.

1 Like

I have the same experience using elementary OS (Ubuntu based distro), Adminer works on PHP 7.3, fails on 7.4 & 8. Disappointing as WordPress recommends PHP 7.4 or greater and I’m sure we’d all prefer for our local dev environment to mirror production.

I am able to access Adminer running PHP 7.4.1 using the next sequential port number (for example if Adminer opens http://localhost:10006/ I am able to access Adminer using port http://localhost:10007/)

1 Like

Similar case here, but it works with the previous number.

  • I’ve installed a site with PHP 8.0.0 and clicked “Open Adminer”
  • browser opens at port 10006 (error)
  • changed site to PHP 7.3.5 and clicked “Open Adminier”
  • browser opens at port 10005 (works)
  • changed back to PHP 8.0.0 and clicked “Open Adminer”
  • browser opens at port 10006 (error)
  • changed manually the port to 10005 and it works (while still using PHP 8.0.0)
2 Likes

Any idea how to fix this? Adminer is working for us as well using PHP v7.3.5 but shows error on higher versions of PHP.

Thanks for asking! Not a concrete idea yet, but the team is taking a closer look this sprint, so a fix might be available soon!

Hi All :wave: !

Yesterday we put out a stable release for Local 6.2.0 which includes a fix for Adminer on Linux. Check it out and let us know if you’re still experiencing issues.

Links to releases:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.