Cloud backups error

Issue Summary

The ‘Cloud Backups’ section at:Local Hub is not useable for me. It shows a big ‘500 Error’ sign on the screen.
Also, when I try to disconnect my Google account, it says it’s been done but when I login again its still connected. Because of all this, Im unable to use cloud backups. Makes no difference if I clear cache or use different browser.

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?
    Happens on all sites and backup attempts fail

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?


Describe the steps that others can take to replicate this issue. If you have screenshots that can help clarify what is happening, please include them!
Just create a site as normal on Flywheel Local. Install Cloud Backups add-on then try to create a backup, or click on ‘Add or Manage Provider’. either way - the backup fails and the cloud backups page on the Local website shows an error.

System Details

Security Reminder

Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

1 Like

Hey @murph! Sorry, you’re having some trouble here. Let’s run through some basics to see if anything helps:

  • Have you tried restarting Local?
  • Have you tried restarting your machine?
  • Are you running other developer applications simultaneously? Or other intensive programs that could be conflicting and can be shut down?
  • Do you have any antivirus, security, or firewall applications that could be blocking Local?

I can also DM you to verify some details and then check your account settings from my end!

Thanks for replying Nick.
I have restarted Local (twice), after restarting my mac
No other apps running, apart from Spotify.
No anti-virus or firewall (only an anti-porn block from my ISP)

Sending you email address in DM

Hi @murph

Sorry for the misunderstanding but I thought that error was coming from within the App.

Anyways, I checked your email and tried accessing Cloud Backups under your user and got the same error. I disconnected your Google Account which was still enabled, so you should be good to try again fresh now if you want!

Keep us posted

Thanks Nick. So I dont get the error on the add-ons page now (thank you!), but every attempt at creating a backup fails, on any website. Again, I have no firewalls running. Ive attached the logs. Any ideas what could be wrong?
Thanks (30.5 KB)

Hi @murph

If you create a new, blank WordPress site are you able to back that up? Or do you get the same error?

Another possibility could be a network issue. Are you able to connect to a different network and try that? Or test with a VPN/LTE data hotspot?

same situation with you bro. Any solution to this? or should I revert back to the previous version of localwp?

Same for any new site and all sites. I use a VPN - makes no difference. I’m using Updraft Plus instead now. thanks for your efforts anyway Nick

No solution yet unfortunately!

thanks. I REALLY hope next time when they release some new update they really need to TEST everything out. because, prior to this version, I have ZERO issues with the backup situation.

Hi @riploxiv

We definitely do extensive testing for each new release and against new features, but that isn’t always a catch-all.

@murph and @riploxiv Something else that might be worth checking…

There may be an issue with your authorization tokens not being accepted. This could mean there is an issue with the time synchronization between Local and the server.
Can you manage your computer’s Date & Time preferences and make sure the computer is automatically setting the time and timezone? Once those have been set, you can try restarting Local and logging in again.

@murph Looking at your log specifically from above, there is a 403 error similar to this other thread, indicating some kind of permissions issue.

Ok Nick, so some progress has been made…

I connected to Dropbox and the backup has worked fine. But still no luck with Google Drive, which is where I really need to backup to!

Date and time are set automatically. I restarted machine and Local, after ensuring no other apps were open at all.

So, there must be something about my Google account it doesn’t like…??

Hi @murph The error in your log is just like the ones here:

So you could start by checking if you have a LocalBackups folder in your Google Drive account. Does it also have a unique hash for the folder that contains the backups?

Sorry Nick I dont really understand that error. But there is no folder in my Google Drive account relating to Local backups. Do I need to create one or should I create one for me?

Hi @murph You shouldn’t need to create one, but all of that is just telling us that something within your machine/network and Google aren’t getting along.

This is more detail about the specific error being thrown: