Connection error on local when pulling from WP Engine

Issue Summary

When pulling (including database) from WP Engine live website to local by flywheel, the local website has a connection error and the wp-admin has a plain UI.

I tried a search and replace via phpMyAdmin but no updated rows.

UPDATE wp_posts SET guid = replace(guid, ‘live website’, ‘local’);
UPDATE wp_posts SET post_content = replace(post_content,‘live website’, ‘local’);
UPDATE wp_links SET link_url = replace(link_url, '‘live website’, ‘local’);
UPDATE wp_links SET link_image = replace(link_image, ‘live website’, ‘local’);
UPDATE wp_postmeta SET meta_value = replace(meta_value,‘live website’, ‘local’);
UPDATE wp_usermeta SET meta_value = replace(meta_value, ‘live website’, ‘local’);
UPDATE wp_options SET option_value = replace(option_value,‘live website’, ‘local’) WHERE option_name = ‘home’ OR option_name = ‘siteurl’;

Then Tried to replace the themes and uninstall the plugins via the wp_options but nothing changed.

Troubleshooting Questions

  • What are the best practices when pulling from WP-engine to Local by Flywheel?


  • Connect via API from Local by Flywheel to WP-engine website
  • Select the Pull, then website, environment, and include the database (optional)
  • Once the Pull has been successful check if its working locally

System Details

  • Which version of WordPress, PHP, Webserver, from WP Engine is being used?
    Wordpress: Version 6.0.1
    Webserver: nginx
    MySQL: 5.7.36

  • Which version of WordPress, PHP, Webserver, MySQL, from Local is being used?
    Wordpress: Version 6.0.1
    Webserver: nginx
    MySQL: 8.0.16

  • Which version of Local is being used?
    Version 6.4.2+6012

  • What Operating System (OS) and OS version is being used?
    macOS Big Sur Version 11.0.1

Local Log

local-lightning.log (419.8 KB)


Hi there @walter-clayton - welcome to the Local community!

Thank you for your question.

I notice for your Router mode you are using localhost have you tried using Site domains when pulling from WP Engine?

I notice the errors in your first screenshot are referencing SSL protocol and the localhost Router mode does not allow for https://.

Do you want to try that?

The Router Mode is updated via Local > Preferences > Advanced > Router Mode

Shared with CloudApp

Sam :woman_technologist:t3:

Hello @sambrockway,

Thank you very much for welcoming me to the community :blush:

I made your recommended changes and they worked!

Thank you :pray:

1 Like

Hi there, @walter-clayton -

So happy to know that it helped! :tada:

Can’t wait to hear about what you create with Local.

Sam :woman_technologist:t3:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.