Error 504 with the Live Link

Good afternoon from Brazil,

I’am currently having problems with the Live Links mecanism.

Some sites i can’t turn the Live Links option, the switch flickers off and after a couple of minutes it shows the following error:

“Request failed with status code 504”

I’ll attach the full error image.

By the way, there is only 1 site that is actually working with the Live Link.
Nothing out of the usual was done to it.

Dell Inspiron 1500
Linux Ubuntu 20.04
Local 7.1.0

Captura de tela de 2023-07-25 13-16-14

Hi @enokidajoaquim

This is likely due to some type of network or connection interference. You could try restarting your site, your app or your machine.

You could also check and see if you’re running any other Developer applications or security applications that could be blocking or limiting Local.

@Nick-B Hi, how can i check that?

Are you running other developer applications simultaneously? Apps like MAMP, XAMPP, or Docker for example.

Do you have any antivirus, security, or firewall applications running?

If you’re not familiar with how to check your machine for open programs or other runnings tasks you might need to search around. You could start here maybe:

https://www.cyberciti.biz/faq/how-to-check-running-process-in-ubuntu-linux-using-command-line/

Well, i don’t know how to tell what process maybe interfering.

I’ll post a print of the current processes.

As for the applications, i didn’t install any applications in the interval of when it used to work normally aside from postgres, node and nginx, which failed btw.

You mentioned it still works normally for one site, but only with other sites you get the 504? Are you running all of the sites at the same time? What I mean is that if there is a site you want to use the Live Link on have you “Stopped” all of the other sites in your app first? It could be the machine is just getting overloaded.

You might try running through our guide below:

Yea, it used to work. I would usually run 3 sites without breaking a sweat.
Suddenly it just stopped working for 2/3 sites. One of which has been a while since I even modify its code.

I tried troubleshooting it based on the tips on link and it still gives back the same error.

If I reinstall the app could it work?

You could give that a try if you wish!

The steps you’d want to take would look something like this:

  • Export any sites that you have on Local and save them to a folder somewhere on your computer.

  • Fully uninstall Local from your computer.

  • Install the latest version of Local on this link.

  • Once installed, please restart the computer.

  • When the computer is restarted and turned on, close any applications that automatically run in the background (AntiVirus, Firewall, and other Developer applications included).

  • Check and see if the issue still persists

All aight, Iam gonna give it a try.

Good morning,

I tried reinstalling the app but it didn’t work.

For the moment I’ll just wait, I think that it could be a problem with the Local server, which is fine be me for the time being.

Thanks for the help btw.

God bless.

When you’re getting these errors is this on a home network? Or are you working from an office somewhere?

Do you utilize a VPN or mobile hotspot?

Working on a home network, without vpn and hopspot.

And strangly enough, its working again hehe

Glad to hear it’s working again! This error is tough to troubleshoot since it’s usually sporadic. Generally, it’s some type of connection problem so if you come across it again it might be good to just try doing some reboots of Local or your machine. Making sure other sites and programs are stopped/closed down.

Will do.

Thanks man, may God bless!