Every time I start a site in local my Mac gives me this popup: Do you want the application “httpd” to accept incoming network connections?

Issue Summary

Sometime in the last few months this started happening. I realize it’s a Mac popup, but I am wondering if there is a way I can get my mac to automatically accept these connections so I don’t have to accept every time I open a site in local.

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?

All Sites

System Details

  • Which version of Local is being used?
    7.01 but this was happening in 6.7.2 as well.

  • What Operating System (OS) and OS version is being used?
    macOS Ventura 13.4

Hi @laurayeffeth

It doesn’t look like this is a Local issue but a setting on your machine. I did some Google searching and this thread might be helpful. If that doesn’t work you may need to do some continued research to figure out how to adjust or disable the setting.

Thanks for this. Does anyone know what plist file I need to delete? I don’t see anything related to local or flywheel.

Hey @laurayeffeth

If you’re not seeing anything Local related in there then you may need to try the other options mentioned:

You can simply select "Allow All" in your firewall, or simply turn it off.

Otherwise, you might need to do some more checking around the web to see how else this can be addressed. I don’t see that we’ve had any other Local users bring up this error before, but here are some other threads I’ve found of users encountering this:


@laurayeffeth I’ve had the same problem for about 8 months now. Further info buried in another topic. Seems to be an Apache server only problem.

Thanks everyone. I did find a few plist files but I am pretty sure they are related to older versions of Local. Regardless, deleting them and following the initial suggestion did not help. I couldn’t find an “Allow All” option unless you were referring to the “Automatically allow built-in software to receive incoming connections” which was already checked. I’ve disabled the firewall for now.

@laurayeffeth Does it work for you when you disable the firewall? For me it doesn’t regardless of settings.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.