Install large databse

Issue Summary

I’ve been told that large databases have to be imported after pulling the website. I tried following this tutorial How to Import Large Databases in Local by Flywheel Sites - Igor Benić

But when I get to the step of installing the DB, it says it can’t find the file. When running the command from the actual folder it is in, it then says something about ‘using passwords is not safe’ and stops running.

The Flywheel support then told me to download a back-up from the website and drag that ZIP into local. This should also install the large database according to them, as explained here Import/Export a WordPress Site - Local
This unfortunatly results in a error message saying ‘please try again with a compatible ZIP file’.

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?
    Only this one

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?
    I can acces my other sites, yes


Describe the steps that others can take to replicate this issue. If you have screenshots that can help clarify what is happening, please include them!

System Details

  • Which version of Local is being used?

  • What Operating System (OS) and OS version is being used?

    • For example: macOS Catalina or Windows 10 Professional
      macOS High Sierra version 10.13.6 and Windows 11 home version 22H2
  • Attach the Local Log. See this Help Doc for instructions on how to do so:

Security Reminder

Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi there @Duet -

You may be on a version of Local that is not supported for your OS (macOS High Sierra 10.13.6).

See this help doc about downgrading Local for more information:

Specifically, this blurb -

After Local v6.5, we cannot ensure compatibility below macOS Catalina (10.15). If you’re on an older version of macOS, you’ll need to install a version of Local prior to version 6.5.

I might recommend downgrading Local to a version previous to 6.5 (but I would make a backup of anything you have in Local already ahead of that).

Let me know if that helps,


Hi @sambrockway ,

I downgraded to 6.4.3. Then tried to drag my .ZIP file into local for installation. Unfortunately I got tis error:
Screen Shot 2023-06-08 at 10.16.38
(Error: Local was unable to import the following SQL files)

Also trying to pull the website results in " Uh-oh! We ran into an issue when pulling from Flywheel."

But this issue seems to be happening on an up-to-date Windows as well.

The WP Migrate plugin has never let me down.


I’m also using the macOS database app Querious to be able to fix various issues. I have been running the new version 4 beta for a while and I guess it will be released very soon.

1 Like

Hi @Duet -

@emmtre brings up a good point - the WP Migrate Pro plugin might be a good option to try. Have you given that a go?


Thanks @emmtre and @sambrockway

I’ll have a look at it after the weekend.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.