Local Community

Installing localWP stopped my existing local Mac Web Server from working

Issue Summary

One or two sentence summary of the issue.

Installing localWP stopped my existing local Mac Web Server from working. If I try access my existing webpages (after closing localWP and also restarted my Mac) made with Mac web server, I got this error message:
“404” error and the warning" Site Not Found on my - The site you requested does not have an associated route in Local."
It seems that localWP has “taken over” or adjusted something in my Mac OS.

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?
    Yes
    An example of my URL that worked before installing localWP: localhost/~2ms/no_som_Server

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?
    I can’t do anything in my local Mac Web Server anomore.

Replication

Describe the steps that others can take to replicate this issue. If you have screenshots that can help clarify what is happening, please include them!
I just installed localWP and tested it and it worked fine.
Then I tried access my existing webpages, I got this error.

System Details

  • Which version of Local is being used?
    6.4.0

  • What Operating System (OS) and OS version is being used?

    • For example: macOS Catalina or Windows 10 Professional

Mac OS High Sierra.

  • Attach the Local Log. See this Help Doc for instructions on how to do so:

Security Reminder

Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hello there @salmon12kg - thank you for bringing your question to the Local Community! :wave:

Did you by chance update the site domain of the site you’re working on? (see below)

Shared with CloudApp

Or did this happen immediately after installing Local?

Also, I noticed you are using version 6.4.0 of Local - there is a new version available if you want to try that also: Releases - Local

  • I did not update the Site Domain in localwp.

  • I installed localwp for some days ago but I did not check my existing sites made on my local Mac web server (apache, php and mysql enabled in mac os) before yesterday when I got this problem. So therefor its hard to tell if this happen immediately after installing localwp.

  • I uninstalled localwp (with AppCleaner to get ride of all files) today and now my Mac web server and existing Sites buildt there works again.

  • I am not sure I dare to try localwp again even if you say it now is a never versjon.

Regards
Tom Løkka

tor. 23. jun. 2022 kl. 14:44 skrev Sam Munoz via Local Community <community@localwp.com>:

Hi there, Tom @salmon12kg. :wave:

I’m sorry that the other sites on the computer were having issues when Local was installed and I completely understand being hesitant to give Local another try.

Thanks for explaining what you were experiencing.

If you are interested in using the latest version of Local, I’d recommend using “localhost Router Mode” which can be found under Local’s “Preferences > Advanced > Router Mode” screen.

More details about this setting can be found in this help doc:

Basically, this setting allows Local to play nicer with other server software running on your computer by not using the default HTTP port of 80.

Let me know if that helps!

Sam :woman_technologist:t3:

Thanks for answering :slightly_smiling_face:
If I try again I will tell you :slightly_smiling_face:

man. 27. jun. 2022, 19:35 skrev Sam Munoz via Local Community <community@localwp.com>:

1 Like

Sounds great @salmon12kg - we appreciate you!

Sam :woman_technologist:t3: