Issue with Local WP Version 8.1.0+6514: Chrome displaying '404 Page Not Found' Error"

I have been using the Local WP for a few weeks without any problems. However, last night, I encountered an issue when trying to access my local sites in Google Chrome. Instead of my websites, I received a “404 Oops… page not found” error message with the text “powered by SCE CDN engine v2.66 - cachezone.net.” Interestingly, everything worked perfectly fine in Safari. This issue seems to be exclusive to Chrome (Version 120.0.6099.109, Official Build, arm64).

I attempted various troubleshooting steps, including rebooting my system, clearing the cache, and more, but none of these actions resolved the issue. The only thing that temporarily worked was resetting Chrome to its default settings. However, this solution was short-lived, as the error reappeared this morning. It almost seems as if Chrome is running some kind of CDN server on my machine.

I am running this setup on macOS Sonma 14.2 (23C64) with Local WP Version 8.1.0+6514. Has anyone else experienced this issue, and does anyone have a solution for resolving it?

Thanks very much!
Richard


Hi @RichardReed

When you open up your Dev Console in Chrome does it show an further errors or messaging?

I also noticed the Chrome URL shows that it’s Not Secure. If you add HTTPS to the URL like https://localwp.com/ does it load?

I’ve pinpointed the source of the problem: it turns out to be the VPN.AC Chrome extension. When the VPN is activated, it causes this issue.

When the “Not Secure” warning appears, it happens exclusively for local WordPress pages, even though they use HTTPS. I’m uncertain if this is a standard behavior for Local WordPress. There are no issues when using a web hosting server. Should I see this message?

I also attempted to enable SSL trust in the application, but encountered an error message stating, “Heads-up! There was a problem with trusting the local SSL certificate.” The exact nature of the issue is unclear.

Richard


We have some documentation below that can help with troubleshooting SSL issues in Local. Sometimes it can be browser or extension specific and other times something in the machine.

I have the same issue (possibly). The local site was running fine a week ago, but now I get a 404 error on posts. It’s also working fine online of course.

I am on the latest version of Local (8.2) on Windows 11. I have local SSL enabled.

For me there are no errors shown in Console.

After restarting Local I am getting this error:

(Before it was starting the site, but gave 404 errors)

It’s so strange, Local had been running so reliably for many months.

Hi @seltzdesign

If you create a new, blank site in Local can you access that okay? If you can, then you may want to try reimporting the site getting the errors. The steps would look like this:

  • Locate the site files on your machine, and save a copy of them to your desktop. If you click Go to Site Folder under your site name it should take you right to where they are located.
  • Once you have those copied, completely delete the site from Local
  • Restart Local/your machine
  • Reimport the site back into Local. You can refer here on how to Restore from only Local site files